<!doctype html><html lang="en"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><meta name="theme-color" content="#262626"><title>This Week’s 20 Funniest Tweets 7-6-18</title><script>!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");
apstag.init({pubID: '3342',adServer: 'googletag'
});</script><script type="text/javascript" src="https://secureassets.evolvemediallc.com/prebid/prebid_1_13_custom_120620181417.js" async></script><script>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</script><script async src="https://www.googletagservices.com/tag/js/gpt.js"></script><script>if (adUnits.length > 0) {console.time('[PB DEBUG] pbjs.requestBids');pbjs.que.push(function() {console.info('[PB DEBUG] ----- PBJS Add units %o', adUnits);pbjs.addAdUnits(adUnits);pbjs.bidderSettings = {standard: {adserverTargeting: [{key: "hb_bidder",val: function(bidResponse) {return bidResponse.bidderCode;}}, {key: "hb_adid",val: function(bidResponse) {return bidResponse.adId;}}, {key: "hb_pb",val: function(bidResponse) {var cpm = bidResponse.cpm;if (cpm <= 1.00) {return (Math.floor(cpm * 100) / 100).toFixed(2);} else if (cpm <= 5.00) {return (Math.floor(cpm * 10) / 10).toFixed(2);} else if (cpm <= 20.00) {return (Math.floor(cpm * 2) / 2).toFixed(2);} else {return '20.00';}}}, {key: "hb_size",val: function(bidResponse) {return bidResponse.size;}}]
}};
fetchHeaderBids();});} else {console.info('[PB DEBUG] ----- PBJS No ad units');fetchHeaderBids(false, true);}</script><script>PB                       = window.PB || {};PB.gptAds                = PB.gptAds || {};PB.gptWaitSidebarLoaded  = false;PB.gptRefreshSRA         = false;PB.gptRefreshSSAds       = false;PB.gptRefreshListicleAds = false;PB.gptAdUnitId           = '/4403/cr/mandatory/fun';googletag.cmd.push(function() {if (!(typeof(window.I11C) !== 'undefined' && window.I11C.Morph == 1)) {PB.gptAds['adoop'] = googletag.defineOutOfPageSlot('/4403/cr/mandatory/fun', 'adoop').addService(googletag.pubads());} else {googletag.pubads().setTargeting('instartLogic', '1');PB.gptAdUnitId = '0';}googletag.pubads().setTargeting('ct', 'article').setTargeting('ci', '1452749').setTargeting('content_detail', '1').setTargeting('kw', 'fun,funniest-tweets,funny,funny-photos,funny-tweets,funny-twitter,humor,the-latest,tweets,tweets-7-6-18,tweets-of-the-week,twitter').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.pubads().enableSingleRequest();googletag.pubads().disableInitialLoad();googletag.pubads().collapseEmptyDivs(true);googletag.enableServices();});var sbIngageTargeting = {custom_params: [
{ ct : "article" },{ ci : "1452749" },{ content_detail : "1" },{ kw : "fun,funniest-tweets,funny,funny-photos,funny-tweets,funny-twitter,humor,the-latest,tweets,tweets-7-6-18,tweets-of-the-week,twitter" },{ coppa : "0" },{ site : "mandatory" },],zone : 'fun'
}</script> <meta name="description" content="It probably feels nice to just step away from Twitter once in awhile. Besides, you can get your fix of the very best tweets 7-6-18 right here every Friday to catch up." /><link rel="canonical" href="http://www.mandatory.com/fun/1452749-this-weeks-20-funniest-tweets-7-6-18" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="This Week’s 20 Funniest Tweets" /><meta property="og:description" content="It probably feels nice to just step away from Twitter once in awhile. Besides, you can get your fix of the very best stuff right here every Friday to catch up." /><meta property="og:url" content="http://www.mandatory.com/fun/1452749-this-weeks-20-funniest-tweets-7-6-18" /><meta property="og:site_name" content="Mandatory" /><meta property="article:author" content="https://www.facebook.com/cordak" /><meta property="article:tag" content="funniest tweets" /><meta property="article:tag" content="funny" /><meta property="article:tag" content="funny tweets" /><meta property="article:tag" content="funny twitter" /><meta property="article:tag" content="humor" /><meta property="article:tag" content="the latest" /><meta property="article:tag" content="tweets" /><meta property="article:tag" content="tweets 7-6-18" /><meta property="article:tag" content="tweets of the week" /><meta property="article:tag" content="Twitter" /><meta property="article:section" content="Fun" /><meta property="article:published_time" content="2018-07-06T11:57:14-07:00" /><meta property="article:modified_time" content="2018-07-06T11:57:47-07:00" /><meta property="og:updated_time" content="2018-07-06T11:57:47-07:00" /><meta property="og:image" content="http://cdn2-www.mandatory.com/assets/uploads/2018/07/tweets-7-6-18.jpg" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="422" /><meta property="og:image:alt" content="tweets 7-6-18" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="It probably feels nice to just step away from Twitter once in awhile. Besides, you can get your fix of the very best stuff right here every Friday to catch up." /><meta name="twitter:title" content="This Week’s 20 Funniest Tweets" /><meta name="twitter:image" content="http://cdn2-www.mandatory.com/assets/uploads/2018/07/tweets-7-6-18.jpg" /><meta name="twitter:creator" content="@corydudak" /><link rel="amphtml" href="http://www.mandatory.com/fun/1452749-this-weeks-20-funniest-tweets-7-6-18/amp" /><link rel='dns-prefetch' href='//www.springboardplatform.com' /><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.mandatory.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=352"}};!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);</script><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important}</style><link rel='stylesheet' type='text/css' media='all' href='http://cdn2-www.mandatory.com/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/pb-slideshow/assets/css/slideshow.css,wp-content/plugins/pb-cover-panel/widget/assets/css/jquery.coverpanel.css,wp-content/plugins/wp-to-twitter/css/twitter-feed.css,wp-content/plugins/wp-lightbox-2/styles/lightbox.min.css&amp;ver=a5777e2922e1be4678a6b5175ccf0f1ab3b513d9' /><link rel='stylesheet' type='text/css' media='screen' href='http://cdn1-www.mandatory.com/wp-content/plugins/bwp-minify/min/?f=wp-content/mu-plugins/general-css/general-styles.css,wp-content/plugins/nextgen-gallery/css/nggallery.css,wp-content/themes/mandatory-2018/css/main.css&amp;ver=a5777e2922e1be4678a6b5175ccf0f1ab3b513d9' /><script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.8.3/jquery.min.js'></script><script type='text/javascript' src='http://cdn3-www.mandatory.com/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/pebblebed/media/js/htmlParser.js,wp-content/plugins/pebblebed/media/js/postscribe.min.js,libraries/pebblebed/js/gn_country.js,wp-content/plugins/pebblebed/media/js/modernizr.js,wp-content/plugins/pebblebed/media/js/pb.core.js,wp-content/plugins/pebblebed/media/js/jquery.ba-resize.js,wp-content/plugins/wp-evolve-gpt/js/pb.resize-iframe.js,wp-content/plugins/wp-evolve-gpt/js/pb.gpt-builder.js&amp;ver=a5777e2922e1be4678a6b5175ccf0f1ab3b513d9'></script><link rel='https://api.w.org/' href='http://www.mandatory.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.mandatory.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://cdn1-www.mandatory.com/wp-includes/wlwmanifest.xml" /> <link rel='shortlink' href='http://www.mandatory.com/?p=1452749' /><link rel="alternate" type="application/json+oembed" href="http://www.mandatory.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.mandatory.com%2Ffun%2F1452749-this-weeks-20-funniest-tweets-7-6-18" /><link rel="alternate" type="text/xml+oembed" href="http://www.mandatory.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.mandatory.com%2Ffun%2F1452749-this-weeks-20-funniest-tweets-7-6-18&#038;format=xml" /><script>(function (win) {var PB = win.PB || {};PB.wpQueryVars = {query : 'a:10:{s:13:\"category_name\";s:3:\"fun\";s:3:\"tag\";s:0:\"\";s:1:\"p\";i:1452749;s:8:\"pagename\";s:0:\"\";s:9:\"post_type\";s:0:\"\";s:11:\"author_name\";s:0:\"\";s:8:\"taxonomy\";s:0:\"\";s:4:\"term\";s:0:\"\";s:4:\"home\";i:0;s:12:\"is_sponsored\";b:0;}'
};win.PB = PB;}(window));</script><script>(function (win) {var PB = win.PB || {};PB.Wibbitz = {source      : '//cdn4.wibbitz.com/mandatory/embed.js',imagePlayer : 'embed-main-image',mainPlayer  : 'embed-main-player',hasATF      : true,selector    : 'featured-image'
};}(window));</script><script type="text/javascript">//              DO NOT IMPLEMENT                //
//       this code through the following        //
//                                              //
//   Floodlight Pixel Manager                   //
//   DCM Pixel Manager                          //
//   Any system that places code in an iframe   //
(function () {var s = document.createElement('script');s.type = 'text/javascript';s.async = true;s.src = ('https:' == document.location.protocol ? 'https://s' : 'http://i')
+ '.po.st/static/v4/post-widget.js#publisherKey=30q4es4jdfhnjm1jk3ru';var x = document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s, x);})();</script><link rel="shortcut icon" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon.ico"><link rel="shortcut icon" sizes="16x16" href="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon-16x16.png"><link rel="shortcut icon" sizes="32x32" href="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon-32x32.png"><link rel="shortcut icon" sizes="96x96" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon-96x96.png"><link rel="apple-touch-icon" href="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon.png"><link rel="apple-touch-icon" sizes="57x57" href="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-57x57.png"><link rel="apple-touch-icon" sizes="60x60" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-60x60.png"><link rel="apple-touch-icon" sizes="72x72" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-72x72.png"><link rel="apple-touch-icon" sizes="76x76" href="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-76x76.png"><link rel="apple-touch-icon" sizes="114x114" href="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-114x114.png"><link rel="apple-touch-icon" sizes="120x120" href="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-120x120.png"><link rel="apple-touch-icon" sizes="144x144" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-144x144.png"><link rel="apple-touch-icon" sizes="152x152" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-152x152.png"><link rel="apple-touch-icon" sizes="180x180" href="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-180x180.png"><link rel="apple-touch-icon" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-precomposed.png"><meta name="msapplication-TileImage" content="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-70x70.png"><meta name="msapplication-TileImage" content="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-144x144.png"><meta name="msapplication-TileImage" content="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-150x150.png"><meta name="msapplication-TileImage" content="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-310x310.png"><link rel="icon" type="image/png" sizes="36x36" href="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-36x36.png"><link rel="icon" type="image/png" sizes="48x48" href="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-48x48.png"><link rel="icon" type="image/png" sizes="72x72" href="http://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-72x72.png"><link rel="icon" type="image/png" sizes="96x96" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-96x96.png"><link rel="icon" type="image/png" sizes="144x144" href="http://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-144x144.png"><link rel="icon" type="image/png" sizes="192x192" href="http://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-192x192.png"><script>(function (win) {var PB = win.PB || {};PB.WPQuery = {tagSlug      : '',authorId     : '',}}(window));</script><script type="text/javascript">var gptRefreshTimer = 30;</script><style type="text/css">.girl-videos{display:none}@-moz-document url-prefix(){.post-listed-image img{position:relative;top:0;height:100%;object-fit:cover}.post-listed-image{overflow:hidden;position:relative;height:auto;padding:0;padding-top:0px}.home .post-listed:nth-of-type(5) .post-listed-image,.home .post-listed:nth-of-type(6) .post-listed-image,.home .post-listed:nth-of-type(12) .post-listed-image,.home .post-listed:nth-of-type(13) .post-listed-image{padding-top:0;width:50%}}.menu-wildaboutmovies a:before{background:#205b83}.leaderboard{z-index:9999999999}.top-logo{background:url("http://cdn1-www.mandatory.com/assets/uploads/2018/06/logo_ma.svg") no-repeat center center}</style><script data-cfasync='false' type='text/javascript'>if ($(window).width() > 789) {(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/861257fe-ea38-4932-9177-2d3751496709.js');}</script><script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script><link href="https://fonts.googleapis.com/css?family=Libre+Franklin:400,400i,700|Oswald:400,600,700" rel="stylesheet"></head><body class="post-template-default single single-post postid-1452749 single-format-standard single-default"><header class="header"><div class="header-container"><button class="toggle-menu js-menu-btn"><span class="lines"></span></button><a href="/" class="top-logo"><div id="custom_html-14" class="widget_text widget_custom_html"><div class="textwidget custom-html-widget"><img class="big no-lazy" src="http://cdn1-www.mandatory.com/assets/uploads/2018/06/logo_ma.svg" /><img class="small no-lazy" src="http://cdn1-www.mandatory.com/assets/uploads/2018/06/logo_ma_small.svg" /></div></div></a><div class="top-main-nav"><div class="menu-categories-container"><ul id="menu-categories" class="menu"><li id="menu-item-1398160" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1398160"><a href="http://www.mandatory.com/fun">Fun</a></li><li id="menu-item-1398154" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1398154"><a href="http://www.mandatory.com/culture">Culture</a></li><li id="menu-item-1398165" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1398165"><a href="http://www.mandatory.com/living">Living</a></li><li id="menu-item-1398163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398163"><a href="http://www.mandatory.com/girls">Girls</a></li><li id="menu-item-1398164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398164"><a href="http://www.mandatory.com/inspire">Inspire</a></li><li id="menu-item-1398173" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398173"><a href="http://www.mandatory.com/the-world">The World</a></li></ul></div></div><div class="top-social-menu js-social"><div class="ad-choices-logo-navbar"><div id="custom_html-13" class="widget_text widget_custom_html promo pb-slideshow-ad-container"><span class="hidden">AdChoices Logo</span><div class="textwidget custom-html-widget"><div data-glade data-ad-unit-path="/4403/cr/mandatory" height="13" width="70"></div><script async='async' src='https://securepubads.g.doubleclick.net/static/glade.js'></script></div></div></div><div class="menu-social-media-container"><ul id="menu-social-media" class="menu"><li id="menu-item-1398188" class="menu-fb menu-item menu-item-type-custom menu-item-object-custom menu-item-1398188"><a target="_blank" href="https://www.facebook.com/MANDATORY/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.facebook.com']);">Facebook</a></li><li id="menu-item-1398189" class="menu-tw menu-item menu-item-type-custom menu-item-object-custom menu-item-1398189"><a target="_blank" href="https://twitter.com/Mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://twitter.com']);">Twitter</a></li><li id="menu-item-1398190" class="menu-in menu-item menu-item-type-custom menu-item-object-custom menu-item-1398190"><a target="_blank" href="https://www.instagram.com/mandatorydotcom/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.instagram.com']);">Instagram</a></li><li id="menu-item-1407431" class="menu-ac menu-item menu-item-type-custom menu-item-object-custom menu-item-1407431"><a href="http://www.mandatory.com/cookies"></a></li></ul></div><div class="toggle-social js-social-btn"><div class="toggle-dots"></div></div></div><div class="top-search js-search-btn"><svg width="18" height="18" xmlns="http://www.w3.org/2000/svg">><path id="svg_2" d="m15.707,14.293l-3.961,-3.968c0.785,-1.074 1.254,-2.393 1.254,-3.826c0,-3.59 -2.911,-6.499 -6.5,-6.499c-3.59,0 -6.5,2.909 -6.5,6.499s2.91,6.5 6.5,6.5c1.436,0 2.757,-0.471 3.833,-1.259l3.959,3.966c0.391,0.391 1.023,0.391 1.414,0s0.391,-1.023 0.001,-1.413zm-9.207,-3.294c-2.485,0 -4.5,-2.015 -4.5,-4.5s2.015,-4.5 4.5,-4.5c2.486,0 4.5,2.015 4.5,4.5s-2.014,4.5 -4.5,4.5z" fill="#FFF"></path></svg></div></div></header><div class="menu-sidebar js-menu"><div class="sidebar-nav-main"><h3>Navigation</h3><div class="menu-categories-container"><ul id="menu-categories-1" class="js-collapse-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1398160"><a href="http://www.mandatory.com/fun">Fun</a><ul class="sub-menu"><li id="menu-item-1398161" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1398161"><a href="http://www.mandatory.com/fun/funny-photos">Funny Photos</a></li><li id="menu-item-1398162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398162"><a href="http://www.mandatory.com/fun/weird-news">Weird News</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1398154"><a href="http://www.mandatory.com/culture">Culture</a><ul class="sub-menu"><li id="menu-item-1398155" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398155"><a href="http://www.mandatory.com/culture/entertainment">Entertainment</a></li><li id="menu-item-1398156" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398156"><a href="http://www.mandatory.com/culture/gaming">Gaming</a></li><li id="menu-item-1398158" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398158"><a href="http://www.mandatory.com/culture/music">Music</a></li><li id="menu-item-1398159" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398159"><a href="http://www.mandatory.com/culture/sports">Sports</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1398165"><a href="http://www.mandatory.com/living">Living</a><ul class="sub-menu"><li id="menu-item-1398166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398166"><a href="http://www.mandatory.com/living/food-and-drink">Food &#038; Drink</a></li><li id="menu-item-1398169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398169"><a href="http://www.mandatory.com/living/sex-and-relationships">Sex and Relationships</a></li><li id="menu-item-1398167" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398167"><a href="http://www.mandatory.com/living/gear">Gear</a></li><li id="menu-item-1398170" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398170"><a href="http://www.mandatory.com/living/style">Style</a></li><li id="menu-item-1398168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398168"><a href="http://www.mandatory.com/living/life-hacks">Life Hacks</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398163"><a href="http://www.mandatory.com/girls">Girls</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398164"><a href="http://www.mandatory.com/inspire">Inspire</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1398173"><a href="http://www.mandatory.com/the-world">The World</a></li></ul></div></div><div class="sidebar-nav-sites"><h3>More from our channels</h3><div class="menu-our-channels-container"><ul id="menu-our-channels" class="menu"><li id="menu-item-1398179" class="menu-cs menu-item menu-item-type-custom menu-item-object-custom menu-item-1398179"><a href="http://www.comingsoon.net/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.comingsoon.net']);">ComingSoon</a></li><li id="menu-item-1398180" class="menu-gr menu-item menu-item-type-custom menu-item-object-custom menu-item-1398180"><a href="http://www.gamerevolution.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.gamerevolution.com']);">GameRevolution</a></li><li id="menu-item-1398181" class="menu-sd menu-item menu-item-type-custom menu-item-object-custom menu-item-1398181"><a href="http://www.sherdog.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.sherdog.com']);">Sherdog</a></li><li id="menu-item-1398182" class="menu-wz menu-item menu-item-type-custom menu-item-object-custom menu-item-1398182"><a href="http://www.mandatory.com/wrestlezone/">Wrestlezone</a></li><li id="menu-item-1398183" class="menu-shh menu-item menu-item-type-custom menu-item-object-custom menu-item-1398183"><a href="http://www.superherohype.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.superherohype.com']);">SuperHeroHype</a></li><li id="menu-item-1398184" class="menu-psls menu-item menu-item-type-custom menu-item-object-custom menu-item-1398184"><a href="http://www.playstationlifestyle.net/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.playstationlifestyle.net']);">Playstation Lifestyle</a></li><li id="menu-item-1403227" class="menu-wildaboutmovies menu-item menu-item-type-custom menu-item-object-custom menu-item-1403227"><a target="_blank" rel="nofollow" href="https://www.wildaboutmovies.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.wildaboutmovies.com']);">WildAboutMovies</a></li></ul></div></div><div class="sidebar-nav-social"><h3>Follow us on Social Media</h3><div class="menu-social-media-container"><ul id="menu-social-media-1" class="menu"><li class="menu-fb menu-item menu-item-type-custom menu-item-object-custom menu-item-1398188"><a target="_blank" href="https://www.facebook.com/MANDATORY/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.facebook.com']);">Facebook</a></li><li class="menu-tw menu-item menu-item-type-custom menu-item-object-custom menu-item-1398189"><a target="_blank" href="https://twitter.com/Mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://twitter.com']);">Twitter</a></li><li class="menu-in menu-item menu-item-type-custom menu-item-object-custom menu-item-1398190"><a target="_blank" href="https://www.instagram.com/mandatorydotcom/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.instagram.com']);">Instagram</a></li><li class="menu-ac menu-item menu-item-type-custom menu-item-object-custom menu-item-1407431"><a href="http://www.mandatory.com/cookies"></a></li></ul></div></div></div><div class="search-form js-search"><form role="search" method="get" action="http://www.mandatory.com/search"><div class="search-wrap"><input type="search" class="search-form-input js-search-form-input" placeholder="Search…" name="q" value="" /></div></form></div><div class="container"><div class="leaderboard js-leaderboard"><div id="billboard-close-btn" class="billboard-close-btn"><svg version="1.1" id="Capa_1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px" viewBox="0 0 455.992 455.992" style="enable-background:new 0 0 455.992 455.992;" xml:space="preserve"><g><g><g><g><path style="fill:#010002;" d="M227.996,0C102.081,0,0,102.081,0,227.996c0,125.945,102.081,227.996,227.996,227.996
c125.945,0,227.996-102.051,227.996-227.996C455.992,102.081,353.941,0,227.996,0z M227.996,425.593
c-108.952,0-197.597-88.645-197.597-197.597S119.044,30.399,227.996,30.399s197.597,88.645,197.597,197.597
S336.948,425.593,227.996,425.593z" /><path style="fill:#010002;" d="M312.142,122.358l-83.538,83.568l-74.965-83.568c-5.928-5.928-15.565-5.928-21.492,0
c-5.928,5.928-5.928,15.565,0,21.492l74.965,83.568l-84.723,84.723c-5.928,5.928-5.928,15.595,0,21.492
c5.928,5.928,15.565,5.928,21.492,0l83.568-83.538l74.965,83.538c5.897,5.928,15.565,5.928,21.462,0
c5.928-5.898,5.928-15.565,0-21.492l-74.995-83.538l84.723-84.754c5.928-5.928,5.928-15.565,0-21.492
C327.676,116.43,318.07,116.43,312.142,122.358z" /></g></g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g><g></g></svg></div><div id="evolve_ad_gpt_widget-37" class="js-pb-sticky-leaderboard widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="pb_prebidjs_970x250_970x90_728x90_320x150_320x100_320x50_a_1530903476" data-id="pb_prebidjs_970x250_970x90_728x90_320x150_320x100_320x50_a_1530903476" data-offset="0" class="gpt-ad"><script type='text/javascript'>PB        = PB || {};PB.gptStandAlone = PB.gptStandAlone || {};PB.gptAutoRefresh = PB.gptAutoRefresh || {'gptAds':[], 'gptStandAlone':[]};googletag.cmd.push(function() {var standAloneSizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([750, 0], [[728, 90]]).addSize([980, 0], [[970, 250],[970, 90],[728, 90]]).build();PB.gptStandAlone['pb_prebidjs_970x250_970x90_728x90_320x150_320x100_320x50_a_1530903476'] = googletag.defineSlot('/4403/cr/mandatory/fun', [[970, 250],[970, 90],[728, 90]], 'pb_prebidjs_970x250_970x90_728x90_320x150_320x100_320x50_a_1530903476')
.defineSizeMapping(standAloneSizeMapping).addService(googletag.pubads())
.setTargeting('pos', 'A').setTargeting('ct', 'article').setTargeting('ci', '1452749').setTargeting('content_detail', '1').setTargeting('kw', 'fun,funniest-tweets,funny,funny-photos,funny-tweets,funny-twitter,humor,the-latest,tweets,tweets-7-6-18,tweets-of-the-week,twitter').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.enableServices();googletag.display('pb_prebidjs_970x250_970x90_728x90_320x150_320x100_320x50_a_1530903476');googletag.pubads().refresh([PB.gptStandAlone['pb_prebidjs_970x250_970x90_728x90_320x150_320x100_320x50_a_1530903476']]);});</script></div></div><div id="evolve_ad_gpt_widget-38" class="widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="pb_prebidjs_320x150_320x100_320x50_a_1530903476" data-id="pb_prebidjs_320x150_320x100_320x50_a_1530903476" data-offset="0" class="gpt-ad"><script type='text/javascript'>PB        = PB || {};PB.gptStandAlone = PB.gptStandAlone || {};PB.gptAutoRefresh = PB.gptAutoRefresh || {'gptAds':[], 'gptStandAlone':[]};googletag.cmd.push(function() {var standAloneSizeMapping = googletag.sizeMapping().addSize([0, 0], [[320, 150],[320, 100],[320, 50]]).addSize([750, 0], []).addSize([980, 0], []).build();PB.gptStandAlone['pb_prebidjs_320x150_320x100_320x50_a_1530903476'] = googletag.defineSlot('/4403/cr/mandatory/fun', [[320, 150],[320, 100],[320, 50]], 'pb_prebidjs_320x150_320x100_320x50_a_1530903476')
.defineSizeMapping(standAloneSizeMapping).addService(googletag.pubads())
.setTargeting('pos', 'A').setTargeting('ct', 'article').setTargeting('ci', '1452749').setTargeting('content_detail', '1').setTargeting('kw', 'fun,funniest-tweets,funny,funny-photos,funny-tweets,funny-twitter,humor,the-latest,tweets,tweets-7-6-18,tweets-of-the-week,twitter').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.enableServices();googletag.display('pb_prebidjs_320x150_320x100_320x50_a_1530903476');googletag.pubads().refresh([PB.gptStandAlone['pb_prebidjs_320x150_320x100_320x50_a_1530903476']]);});PB.gptAutoRefresh.gptStandAlone.push('pb_prebidjs_320x150_320x100_320x50_a_1530903476');</script></div></div></div><div class="col-left"><article class="post-content"><div class="breadcrumb"><div class="breadcrumb-category"><a href="http://www.mandatory.com/fun" rel="category tag">Fun</a> / <a href="http://www.mandatory.com/fun/funny-photos" rel="subcategory tag">Funny Photos</a></div><div class="breadcrumb-social"><div class="pw-server-widget" data-id="wid-9c0metel" data-via="Mandatory"></div></div></div><div class="featured-image"><figure><img width="750" height="422" src="http://cdn2-www.mandatory.com/assets/uploads/2018/07/tweets-7-6-18.jpg" class="no-lazy wp-post-image" alt="tweets 7-6-18" srcset="http://cdn3-www.mandatory.com/assets/uploads/2018/07/tweets-7-6-18.jpg 750w, http://cdn3-www.mandatory.com/assets/uploads/2018/07/tweets-7-6-18-150x84.jpg 150w, http://cdn3-www.mandatory.com/assets/uploads/2018/07/tweets-7-6-18-390x219.jpg 390w" sizes="(min-width: 1000px), 40vw, 100vw, (max-width: 980px) 766px, (max-width: 750px) 638px, (max-width: 638px) 320px" /></figure></div><h1>This Week’s 20 Funniest Tweets 7-6-18</h1><div class="author-date">by <a href="http://www.mandatory.com/author/cory-dudak" rel="author">Cory Dudak</a> <time datetime="2018-07-06">Jul 6th, 2018</time></div><div wibbitz="embed-main-player"></div><h5><span style="color: #999999;"><em>Header Photo: Universal Pictures / <a href="https://twitter.com/slavetothemic" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);" target="_blank" rel="noopener">@slavetothemic</a> (Twitter)</em></span></h5><p>Another week, another batch of the <a href="http://www.mandatory.com/fun/1451507-funniest-tweets-6-29-18" target="_blank" rel="noopener">funniest tweets</a> collected for your viewing pleasure. Give them a read, and remember to follow these fine folks on Twitter. They’re not just putting their hilarious thoughts out there for their health, after all. Plus, if you’re just going to wind up repeating these jokes to your friends and passing them off as your own, the least you can do is throw a little admiration their way. It’s only fair.</p><p><em>Follow <em><span style="color: #ff0000;"><a style="color: #ff0000;" href="https://twitter.com/Mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);" target="_blank" rel="noopener">@Mandatory</a></span></em> on Twitter.</em></p><div class="pb-in-article-content"><div id="evolve_ad_gpt_widget-31" class="widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="pb_prebidjs_300x250_a" data-id="pb_prebidjs_300x250_a" data-offset="300" class="gpt-ad js-inview"><script type='text/javascript'>PB= PB || {};gptAds= PB.gptAds || {};var opts= {"asBool":false,"adUnit":"\/4403\/cr\/mandatory\/fun","adDiv":"pb_prebidjs_300x250_a","sizeStr":"[[300, 250]]","mapping":[{"viewport":"[0, 0]","sizes":"[[300, 250]]"},{"viewport":"[750, 0]","sizes":"[]"},{"viewport":"[980, 0]","sizes":"[]"}],"targeting":{"pos":"A","ct":"article","ci":"1452749","content_detail":1,"kw":"fun,funniest-tweets,funny,funny-photos,funny-tweets,funny-twitter,humor,the-latest,tweets,tweets-7-6-18,tweets-of-the-week,twitter,mobile-atf","coppa":"0","site":"mandatory"},"resize":false,"autoRefresh":false};PB.waitForAS= (opts.asBool) ? true : PB.waitForAS || false;PB.evGPTBuilder.enqueueAd(opts);</script></div></div></div><h3 style="text-align: center;"><span style="color: #999999; text-align: center;">Funny Tweets 7-6-18</span></h3><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">[driving home from a party]<br></br>MRS. ELEPHANT: you’re still upset aren’t you<br></br>MR. ELEPHANT: i can’t believe they just ignored us like that<br></br>MRS. ELEPHANT: they aren’t worth it, just forget it<br></br>MR. ELEPHANT: *slams steering wheel* you know I can’t do that linda</p><p>— FROVO (@fro_vo) <a href="https://twitter.com/fro_vo/status/1014906455114309632?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 5, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">A reminder for the Fourth. <a href="https://t.co/vNM6mC56hb" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">pic.twitter.com/vNM6mC56hb</a></p><p>— Matt Shirley (@mattsurely) <a href="https://twitter.com/mattsurely/status/1014296904992092160?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 3, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">The hardest part of a break up is that their dog doesn’t know what happened and thinks you just stopped coming over to see him</p><p>— WhitePeopleHumor (@whitememejesus) <a href="https://twitter.com/whitememejesus/status/1011721557113176064?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 26, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">If i have fun today i can’t have fun tomorrow, sorry. <a href="https://t.co/Je42RUFTse" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">https://t.co/Je42RUFTse</a></p><p>— JSM (@X_ch1co_X) <a href="https://twitter.com/X_ch1co_X/status/1011103045223174146?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 25, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">Bosnians : I wanna swim<br></br>Croatia : No <a href="https://t.co/OxFDJgpKd0" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">pic.twitter.com/OxFDJgpKd0</a></p><p>— A NorthEastern guy (@ohNoobDerp) <a href="https://twitter.com/ohNoobDerp/status/1014461661564923905?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 4, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">[first time trying standup]</p><p>Me: So, I was talking to a friend recen-</p><p>*from the back* LOL YEAH RIGHT</p><p>Me: Please, mom, not now</p><p>— Not Sara (@smithsara79) <a href="https://twitter.com/smithsara79/status/1009512594879762437?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 20, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">As much as I use my smartphone, I don’t think I’ve ever seen it in any of my dreams. <a href="https://t.co/1H98pFX9Nv" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">pic.twitter.com/1H98pFX9Nv</a></p><p>— CREDENCE (@BrendanCredence) <a href="https://twitter.com/BrendanCredence/status/1012069764234178560?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 27, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">[First date]</p><p>Her dad: I want her home before midnight</p><p>Me: but you already own her home</p><p>Dad: *turning to daughter* if you don’t sleep with him, I will</p><p>— your bff alex (@psybermonkey) <a href="https://twitter.com/psybermonkey/status/1009448272228909057?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 20, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">Computer, show me the whitest sentence in the world. <a href="https://t.co/XYQELdmj4U" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">https://t.co/XYQELdmj4U</a></p><p>— Glenn Loury 2.0 Darker, Gayer, Different (@justabloodygame) <a href="https://twitter.com/justabloodygame/status/1013444943279423489?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 1, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">Old folks Facebook comments look like visual voicemail.</p><p>“Hey Anthony! How isthe family? We’re good over here. Talk to you later, bye!”</p><p>— Anthony Armstrong (@MrArmstrong13) <a href="https://twitter.com/MrArmstrong13/status/1011422678316707841?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 26, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><h2 style="text-align: center;"><span style="color: #999999;">We already knew that: <a href="http://www.mandatory.com/living/1371377-facebook-just-old-people" target="_blank" rel="noopener"><span style="color: #ff0000;">Facebook Is Now Just for Old People</span></a></span></h2><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">I worked at a bar and a girl came in &amp; got REAL hammered. She started crying and trying to tell me about someone dying… it was someone from Greys Anatomy. She had literally come to drink away the loss of her fictional friend. And I felt that. Like rlly felt it</p><p>— whit:) (@feelingwhitneyd) <a href="https://twitter.com/feelingwhitneyd/status/1013517815897378816?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 1, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">Man, it’s a <a href="https://t.co/fKHXqE6t8r" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">pic.twitter.com/fKHXqE6t8r</a></p><p>— Carlos Toraño (@catorano) <a href="https://twitter.com/catorano/status/1014660251671547907?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 5, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">Jurassic Park but everything goes well and everyone really enjoys it.</p><p>— Mike (@slavetothemic) <a href="https://twitter.com/slavetothemic/status/1015003336133808128?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 5, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">you: dick pics<br></br>me, an intellectual: richard pictures</p><p>— Colette (@colettelverity) <a href="https://twitter.com/colettelverity/status/1012459775752368130?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 28, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">me choosing my outfit everyday <a href="https://t.co/a39XMLw0vw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">pic.twitter.com/a39XMLw0vw</a></p><p>— satan (@vampiregaI) <a href="https://twitter.com/vampiregaI/status/991800622503596033?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">May 2, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">One of my favorite games to play is “is my headache from dehydration, caffeine withdrawal, lack of proper nutrition, my ponytail, stress, lack of sleep, not wearing my glasses or brain tumor?”</p><p>— parker (@pmilbs_) <a href="https://twitter.com/pmilbs_/status/974269138322493442?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">March 15, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">what if your teeth were naturally flaccid and got hard when you got hungry</p><p>— e l l e n b e r g (@EggInBurger) <a href="https://twitter.com/EggInBurger/status/1010978568556380160?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 24, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">Alternate slogans:</p><p>“Ob-la-di, ob-la-da, life goes yarn”</p><p>“Blackbird singing in the dead of yarn”</p><p>“We all live in a yellow submayarn” <a href="https://t.co/j1WE3nufGV" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">pic.twitter.com/j1WE3nufGV</a></p><p>— Nathan Usher (@thenatewolf) <a href="https://twitter.com/thenatewolf/status/1015026727955791872?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">July 6, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">You can say “please” and “thank you” a million times and your toddler will never repeat it, but if you say “ass-faced mother fucker” ONCE…</p><p>— Henpecked Hal (@HenpeckedHal) <a href="https://twitter.com/HenpeckedHal/status/1010175309348462592?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 22, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><blockquote class="twitter-tweet" data-lang="en"><p dir="ltr" lang="en">Me after finally opening up to someone <a href="https://t.co/4731FE47xP" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://t.co']);">https://t.co/4731FE47xP</a></p><p>— nicole. (@idekcolee) <a href="https://twitter.com/idekcolee/status/1012927830185971712?ref_src=twsrc%5Etfw" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);">June 30, 2018</a></p></blockquote><p><script async="" src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p><div class="pagination"></div><div class="pw-server-widget" data-id="wid-kf84dv71"></div><div class="single-bottom"><div id="custom_html-4" class="widget_text widget_custom_html"><span class="hidden">Zergnet Holder</span><div class="textwidget custom-html-widget"><div id="zergnet-widget-63055"></div></div></div><div id="pb_related_posts_widget-2" class="no-hidden widget_pb_related_posts_widget"><span class="hidden">Recent Posts in Category</span><ul class="pb-related-post-list "><li class="pb-related-post pb-related-post-1"><a href="http://www.mandatory.com/fun/1452749-this-weeks-20-funniest-tweets-7-6-18" rel="bookmark"><span class="imgholder"><img src="http://cdn3-www.mandatory.com/assets/uploads/2018/07/tweets-7-6-18-320x249.jpg" alt="This Week’s 20 Funniest Tweets 7-6-18"></span></a><a href="http://www.mandatory.com/fun/1452749-this-weeks-20-funniest-tweets-7-6-18" rel="bookmark"><span class="rel-head">This Week’s 20 Funniest Tweets 7-6-18</span></a></li><li class="pb-related-post pb-related-post-2"><a href="http://www.mandatory.com/fun/1452593-todays-funny-photos-7-6-18" rel="bookmark"><span class="imgholder"><img src="http://cdn2-www.mandatory.com/assets/uploads/2018/07/0_funny_photos_7_6_18-320x249.jpg" alt="Today&#8217;s Funny Photos 7-6-18"></span></a><a href="http://www.mandatory.com/fun/1452593-todays-funny-photos-7-6-18" rel="bookmark"><span class="rel-head">Today&#8217;s Funny Photos 7-6-18</span></a></li><li class="pb-related-post pb-related-post-3"><a href="http://www.mandatory.com/fun/1452497-weeks-funniest-gifs-7-5-18" rel="bookmark"><span class="imgholder"><img src="http://cdn1-www.mandatory.com/assets/uploads/2018/07/0_mandatory_gifs_of_the_week_7_5_18-320x249.gif" alt="The Week&#8217;s Funniest GIFs 7-5-18"></span></a><a href="http://www.mandatory.com/fun/1452497-weeks-funniest-gifs-7-5-18" rel="bookmark"><span class="rel-head">The Week&#8217;s Funniest GIFs 7-5-18</span></a></li><li class="pb-related-post pb-related-post-4"><a href="http://www.mandatory.com/culture/1452487-finally-science-has-delivered-us-a-video-game-toilet" rel="bookmark"><span class="imgholder"><img src="http://cdn3-www.mandatory.com/assets/uploads/2018/07/Skyrim-toilet-320x249.jpg" alt="Finally! Science Has Delivered Us A Video Game-Compatible Toilet"></span></a><a href="http://www.mandatory.com/culture/1452487-finally-science-has-delivered-us-a-video-game-toilet" rel="bookmark"><span class="rel-head">Finally! Science Has Delivered Us A Video Game-Compatible Toilet</span></a></li></ul></div><div id="custom_html-5" class="widget_text widget_custom_html"><span class="hidden">Wibbitz Player Widget</span><div class="textwidget custom-html-widget"><div wibbitz="embed-player-widget"></div></div></div></div><div class="single-tags"><a href="http://www.mandatory.com/tag/funniest-tweets" rel="tag">funniest tweets</a><a href="http://www.mandatory.com/tag/funny" rel="tag">funny</a><a href="http://www.mandatory.com/tag/funny-tweets" rel="tag">funny tweets</a><a href="http://www.mandatory.com/tag/funny-twitter" rel="tag">funny twitter</a><a href="http://www.mandatory.com/tag/humor" rel="tag">humor</a><a href="http://www.mandatory.com/tag/the-latest" rel="tag">the latest</a><a href="http://www.mandatory.com/tag/tweets" rel="tag">tweets</a><a href="http://www.mandatory.com/tag/tweets-7-6-18" rel="tag">tweets 7-6-18</a><a href="http://www.mandatory.com/tag/tweets-of-the-week" rel="tag">tweets of the week</a><a href="http://www.mandatory.com/tag/twitter" rel="tag">Twitter</a></div></article></div><div class="col-right"><div class="col-right-inner js-col-right"><div id="evolve_ad_gpt_widget-34" class="widget_evolve_ad_gpt_widget"><div id="pb_prebidjs_300x600_300x250_a" data-id="pb_prebidjs_300x600_300x250_a" data-offset="0" class="gpt-ad"><script type='text/javascript'>PB= PB || {};gptAds= PB.gptAds || {};var opts= {"asBool":false,"adUnit":"\/4403\/cr\/mandatory\/fun","adDiv":"pb_prebidjs_300x600_300x250_a","sizeStr":"[[300, 250]]","mapping":[{"viewport":"[0, 0]","sizes":"[[300, 250]]"},{"viewport":"[750, 0]","sizes":"[[300, 600],[300, 250]]"},{"viewport":"[980, 0]","sizes":"[[300, 600],[300, 250]]"}],"targeting":{"pos":"A","ct":"article","ci":"1452749","content_detail":1,"kw":"fun,funniest-tweets,funny,funny-photos,funny-tweets,funny-twitter,humor,the-latest,tweets,tweets-7-6-18,tweets-of-the-week,twitter,rightrail-medrec","coppa":"0","site":"mandatory"},"resize":false,"autoRefresh":false};PB.waitForAS= (opts.asBool) ? true : PB.waitForAS || false;PB.evGPTBuilder.enqueueAd(opts);</script></div></div><div id="custom_html-6" class="widget_text insticator-holder widget_custom_html"><span class="hidden">Insticator Holder</span><div class="textwidget custom-html-widget"><div id="insticator-container"><div id="div-insticator-ad-1"></div><div id="insticator-embed"></div><div id="div-insticator-ad-2"></div><script data-cfasync='false' type="text/javascript">Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "5a048a58-c894-4071-8862-f64a433a9bf4"})</script></div></div></div></div></div><div class="single-footer"></div></div><footer class="footer"><div class="logo-footer-mandatory"><a href="/">Mandatory</a></div><div class="footer-copyright"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-1398174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398174"><a href="http://www.mandatory.com/contact">Contact Us</a></li><li id="menu-item-1398177" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1398177"><a href="http://www.craveonlinemedia.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.craveonlinemedia.com']);">Advertiser Info</a></li><li id="menu-item-1398176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398176"><a href="http://www.mandatory.com/privacy">Privacy Policy</a></li><li id="menu-item-1398178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398178"><a href="http://www.mandatory.com/termsofuse">Terms &#038; Conditions</a></li><li id="menu-item-1398175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398175"><a href="http://www.mandatory.com/cookies">AdChoices</a></li></ul></div><div class="copyright">MANDATORY.COM IS A PROPERTY OF <a href="http://www.evolvemediallc.com">EVOLVE MEDIA</a> LLC COMPANY. © 2018 ALL RIGHTS RESERVED.</div></div></footer><aside class="widget_text widget_custom_html scripts"><span class="hidden">Zergnet Script</span><div class="textwidget custom-html-widget"><script language="javascript" type="text/javascript">(function() {var zergnet = document.createElement('script');zergnet.type = 'text/javascript'; zergnet.async = true;zergnet.src = (document.location.protocol == "https:" ? "https:" : "http:") + '//www.zergnet.com/zerg.js?id=63055';
var znscr = document.getElementsByTagName('script')[0];znscr.parentNode.insertBefore(zergnet, znscr);})();</script></div></aside><aside class="widget_text widget_custom_html scripts"><span class="hidden">ChartBeat Script</span><div class="textwidget custom-html-widget"><script type="text/javascript">var _sf_async_config = { uid: 8555, domain: 'mandatory.com', useCanonical: true };(function() {function loadChartbeat() {window._sf_endpt = (new Date()).getTime();var e = document.createElement('script');e.setAttribute('language', 'javascript');e.setAttribute('type', 'text/javascript');e.setAttribute('src','//static.chartbeat.com/js/chartbeat.js');
document.body.appendChild(e);};var oldonload = window.onload;window.onload = (typeof window.onload != 'function') ?
loadChartbeat : function() { oldonload(); loadChartbeat(); };})();</script></div></aside><aside class="widget_text widget_custom_html scripts"><span class="hidden">Nielsen tag</span><div class="textwidget custom-html-widget"><script type="text/javascript" src="//secure-au.imrworldwide.com/v60.js"></script><script type="text/javascript">var pvar = { cid: "au-evolve", content: "0", server: "secure-au" };var trac = nol_t(pvar);trac.record().post();</script><noscript> <div> <img class="lazy lazy-hidden" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="//secure-au.imrworldwide.com/cgi-bin/m?ci=au-evolve&amp;cg=0&amp;cc=1&amp;ts=noscript" width="1" height="1" alt="" /><noscript><img src="//secure-au.imrworldwide.com/cgi-bin/m?ci=au-evolve&amp;cg=0&amp;cc=1&amp;ts=noscript" width="1" height="1" alt="" /></noscript> </div></noscript></div></aside><aside class="widget_text widget_custom_html scripts"><span class="hidden">pingdom</span><div class="textwidget custom-html-widget"><div style="position: absolute; left: -999em">monitoring_string = "f4e9a55d2640cb37b28a2b021fc63f8b"monitoring_string = "d597bbac21cf40e24fffa6cecdf4d8c5 "</div></div></aside><script type="text/javascript">//<![CDATA[
var _gaq = _gaq || [],PB   = window.PB || {};PB.GAAccounts     = ["UA-35762280-1","UA-94323-5","UA-94323-62"];PB.GAAuthor       = 'Cory Dudak';PB.baseDomain     = 'craveonline.com';PB.CheckAMPCID    = false;PB.checkAB        = true;PB.baseRequestUrl = '';(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();//]]></script><div id="adoop" data-id="adoop" class="gpt-ad"></div><script src="//dashboard.evolveplatform.net/contentiq.js"></script><script type='text/javascript' src='http://cdn1-www.mandatory.com/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/pb-ajax-sidebars-2/assets/js/pb.sidebar-loader-v2.js,wp-content/plugins/pb-chartbeat-share/assets/js/chartbeat-share.js,wp-content/plugins/pebblebed/media/js/pb.cookie.notice.js,wp-content/plugins/pebblebed/media/js/pb.beacon.js,wp-content/plugins/wp-evolve-gpt/js/pb.auto-refresh.js,wp-content/plugins/pb-wibbitz/assets/js/pb.wibbitz.js,wp-content/plugins/pebblebed/media/js/pb.mediaquery.js,wp-content/themes/mandatory-2018/js/utils/pb.media-queries.js,wp-content/themes/mandatory-2018/js/modules/pb.header-nav.js,wp-content/themes/mandatory-2018/js/modules/pb.scrollout-header.js,wp-content/themes/mandatory-2018/js/modules/pb.overture-scroll.js,wp-content/plugins/pebblebed/media/js/pb.stickify.js,wp-content/themes/mandatory-2018/js/modules/pb.billboard-close-button.js,wp-content/themes/mandatory-2018/js/controllers/pb.global.js,wp-content/themes/mandatory-2018/js/modules/pb.sticky.js,wp-content/themes/mandatory-2018/js/controllers/pb.single.js,wp-content/plugins/bj-lazy-load/js/bj-lazy-load.min.js,wp-content/plugins/wp-evolve-gpt/js/vendor/jquery.visible.js,wp-includes/js/underscore.min.js,wp-content/plugins/wp-evolve-gpt/js/pb.gpt-ads-callbacks.js&amp;ver=a5777e2922e1be4678a6b5175ccf0f1ab3b513d9'></script><script type='text/javascript' src='http://cdn1-www.mandatory.com/wp-content/plugins/bwp-minify/min/?f=wp-content/plugins/wp-evolve-gpt/js/pb.load-gpt-ads.js,wp-content/plugins/wp-evolve-gpt/js/pb.lazy-load-gpt-ads.js,wp-includes/js/wp-embed.min.js,wp-content/plugins/pb-google-analytics-for-wordpress/js/pb.ga-manager.js,wp-content/plugins/pb-google-analytics-for-wordpress/js/pb.ga-init.js&amp;ver=a5777e2922e1be4678a6b5175ccf0f1ab3b513d9'></script></body></html>