<!doctype html><html lang="en"><head><meta charset="utf-8"><meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no"><meta name="theme-color" content="#262626"><title>The Perfect Carly Rae Jepson Parody to Celebrate National Voter Registration Day</title><script>window.grumi = {key: '2a236ed9-fb8c-429e-ab47-cacac34a3be6'
};</script> <script src="//rumcdn.geoedge.be/grumi-ip.js" async></script><script type="text/javascript" src="https://secureassets.evolvemediallc.com/prebid/prebid_4_2_0_custom_081020201210.js" async></script><script src="https://cdnjs.cloudflare.com/ajax/libs/crypto-js/3.1.2/rollups/aes.js"></script><script>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</script><script async src="https://www.googletagservices.com/tag/js/gpt.js"></script><script>if (adUnits.length > 0) {pbjs.que.push(function() {pbjs.addAdUnits(adUnits);pbjs.bidderSettings = {standard: {adserverTargeting: [{key: "hb_bidder",val: function(bidResponse) {return bidResponse.bidderCode;}}, {key: "hb_adid",val: function(bidResponse) {return bidResponse.adId;}}, {key: "hb_pb",val: function(bidResponse) {var cpm = bidResponse.cpm;if (cpm <= 3.00) {return (Math.floor(cpm * 100) / 100).toFixed(2);} else if (cpm <= 8.00) {return (Math.floor(cpm * 20) / 20).toFixed(2);} else if (cpm <= 20.00) {return (Math.floor(cpm * 2) / 2).toFixed(2);} else {return '20.00';}}}, {key: "hb_size",val: function(bidResponse) {return bidResponse.size;}}]
}};pbjs.setConfig({userSync: {filterSettings: {iframe: {bidders: '*',   // '*' means all bidders
filter: 'include'
}}}});
fetchHeaderBids();});} else {fetchHeaderBids(false, true);}</script><script>var isCoppa              = 1;PB                       = window.PB || {};PB.gptAds                = PB.gptAds || {};PB.gptWaitSidebarLoaded  = false;PB.gptRefreshSRA         = false;PB.gptRefreshSSAds       = false;PB.gptRefreshListicleAds = false;PB.gptAdUnitId           = '/4403/cr/mandatory/culture';googletag.cmd.push(function() {if ( ! ( 'undefined' !== typeof( window.I11C ) && 1 === window.I11C.Morph ) ) {PB.gptAds[ 'adoop' ] = googletag.defineOutOfPageSlot( '/4403/cr/mandatory/culture', 'adoop' ).addService( googletag.pubads() );} else {googletag.pubads().setTargeting( 'instartLogic', '1');PB.gptAdUnitId = '0';}googletag.pubads().setTargeting('ct', 'article').setTargeting('ci', '1555788').setTargeting('content_detail', '4').setTargeting('kw', '2020,2020-democrats,2020-election,announcement,best-of,biden,biden-harris,campaign,candidates,carly-rae-jepson,culture,democrat,donald-trump,election,entertainment,fails,fake-news,fun,funniest,funniest-of-the-week,funny,funny-news,haha,joe-biden,kamala-harris,latest-news,lol,missy-modell,national-voter-registration-day,news,policy,political-news,political-satire,politicians,politics,president,presidential,presidential-election,presidential-race,register,register-to-vote,ridiculous-news,running-mate,satire,senator,social-media,strange-news,todays-funny-photos,trump,vice-president,video,videos,vote,voter-registration,vp,weird-news,listicle').setTargeting('coppa', '0').setTargeting('site', 'mandatory');if ( !window.getUrlVars().coppa ) {isCoppa = 0;}googletag.pubads().setTagForChildDirectedTreatment(isCoppa);googletag.pubads().enableSingleRequest();googletag.pubads().disableInitialLoad();googletag.pubads().collapseEmptyDivs(true);googletag.enableServices();});var sbIngageTargeting = {custom_params: [
{ ct : "article" },{ ci : "1555788" },{ content_detail : "4" },{ kw : "2020,2020-democrats,2020-election,announcement,best-of,biden,biden-harris,campaign,candidates,carly-rae-jepson,culture,democrat,donald-trump,election,entertainment,fails,fake-news,fun,funniest,funniest-of-the-week,funny,funny-news,haha,joe-biden,kamala-harris,latest-news,lol,missy-modell,national-voter-registration-day,news,policy,political-news,political-satire,politicians,politics,president,presidential,presidential-election,presidential-race,register,register-to-vote,ridiculous-news,running-mate,satire,senator,social-media,strange-news,todays-funny-photos,trump,vice-president,video,videos,vote,voter-registration,vp,weird-news,listicle" },{ coppa : "0" },{ site : "mandatory" },],zone : 'culture'
}</script> <meta name="description" content="It’s National Voter Registration Day, and what better way to celebrate (and motivate) voters than a new Missy Modell parody video?"/><link rel="canonical" href="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="The Perfect Carly Rae Jepson Parody to Celebrate National Voter Registration Day" /><meta property="og:description" content="It’s National Voter Registration Day, and what better way to celebrate (and motivate) voters than a new Missy Modell parody video?" /><meta property="og:url" content="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody" /><meta property="og:site_name" content="Mandatory" /><meta property="article:tag" content="2020" /><meta property="article:tag" content="2020 democrats" /><meta property="article:tag" content="2020 election" /><meta property="article:tag" content="announcement" /><meta property="article:tag" content="Best of" /><meta property="article:tag" content="biden" /><meta property="article:tag" content="Biden Harris" /><meta property="article:tag" content="campaign" /><meta property="article:tag" content="candidates" /><meta property="article:tag" content="Carly Rae Jepson" /><meta property="article:tag" content="democrat" /><meta property="article:tag" content="Donald Trump" /><meta property="article:tag" content="election" /><meta property="article:tag" content="fails" /><meta property="article:tag" content="Fake News" /><meta property="article:tag" content="fun" /><meta property="article:tag" content="funniest" /><meta property="article:tag" content="funniest of the week" /><meta property="article:tag" content="funny" /><meta property="article:tag" content="funny news" /><meta property="article:tag" content="haha" /><meta property="article:tag" content="Joe Biden" /><meta property="article:tag" content="Kamala Harris" /><meta property="article:tag" content="latest news" /><meta property="article:tag" content="lol" /><meta property="article:tag" content="Missy Modell" /><meta property="article:tag" content="National Voter Registration Day" /><meta property="article:tag" content="news" /><meta property="article:tag" content="Policy" /><meta property="article:tag" content="political news" /><meta property="article:tag" content="political satire" /><meta property="article:tag" content="politicians" /><meta property="article:tag" content="politics" /><meta property="article:tag" content="president" /><meta property="article:tag" content="presidential" /><meta property="article:tag" content="presidential election" /><meta property="article:tag" content="presidential race" /><meta property="article:tag" content="register" /><meta property="article:tag" content="register to vote" /><meta property="article:tag" content="ridiculous news" /><meta property="article:tag" content="running mate" /><meta property="article:tag" content="satire" /><meta property="article:tag" content="senator" /><meta property="article:tag" content="social-media" /><meta property="article:tag" content="strange news" /><meta property="article:tag" content="today&#039;s funny photos" /><meta property="article:tag" content="Trump" /><meta property="article:tag" content="vice-president" /><meta property="article:tag" content="video" /><meta property="article:tag" content="Videos" /><meta property="article:tag" content="vote" /><meta property="article:tag" content="voter registration" /><meta property="article:tag" content="VP" /><meta property="article:tag" content="weird news" /><meta property="article:section" content="Entertainment" /><meta property="article:published_time" content="2020-09-22T11:58:55-07:00" /><meta property="article:modified_time" content="2020-09-22T12:48:18-07:00" /><meta property="og:updated_time" content="2020-09-22T12:48:18-07:00" /><meta property="fb:app_id" content="1761650577410066" /><meta property="og:image" content="https://cdn2-www.mandatory.com/assets/uploads/2020/09/Vote-e1600800217285.jpg" /><meta property="og:image:secure_url" content="https://cdn2-www.mandatory.com/assets/uploads/2020/09/Vote-e1600800217285.jpg" /><meta property="og:image:width" content="600" /><meta property="og:image:height" content="335" /><meta property="og:image:alt" content="voter" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="It’s National Voter Registration Day, and what better way to celebrate (and motivate) voters than a new Missy Modell parody video?" /><meta name="twitter:title" content="The Perfect Carly Rae Jepson Parody to Celebrate National Voter Registration Day" /><meta name="twitter:image" content="https://cdn2-www.mandatory.com/assets/uploads/2020/09/Vote-e1600800217285.jpg" /><link rel="amphtml" href="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody?amp" /><meta name="generator" content="AMP for WP 1.0.58.5"/><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//widgets.outbrain.com' /><link rel='dns-prefetch' href='//ajax.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Mandatory &raquo; The Perfect Carly Rae Jepson Parody to Celebrate National Voter Registration Day Comments Feed" href="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody/feed" /><script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mandatory.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=782"}};!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);</script><style type="text/css">img.wp-smiley,img.emoji{display:inline !important;border:none !important;box-shadow:none !important;height:1em !important;width:1em !important;margin:0 .07em !important;vertical-align:-0.1em !important;background:none !important;padding:0 !important}</style><link rel='stylesheet' id='pb-slideshow-css' href='https://www.mandatory.com/wp-content/plugins/pb-slideshow/assets/css/slideshow.css?ver=1.1' type='text/css' media='all' /><link rel='stylesheet' id='pb-mu-general-styles-css' href='https://www.mandatory.com/wp-content/mu-plugins/general-css/general-styles.css?ver=1.0.0' type='text/css' media='screen' /><link rel='stylesheet' id='coverpanel-jquery-css' href='https://cdn2-www.mandatory.com/wp-content/plugins/pb-cover-panel/widget/assets/css/jquery.coverpanel.css' type='text/css' media='all' /><link rel='stylesheet' id='spotim-cta-widget-css' href='https://www.mandatory.com/wp-content/plugins/pb-spotim-comments//assets/css/cta-widget.css' type='text/css' media='all' /><link rel='stylesheet' id='bodhi-svgs-attachment-css' href='https://www.mandatory.com/wp-content/plugins/svg-support/css/svgs-attachment.css' type='text/css' media='all' /><link rel='stylesheet' id='wpt-twitter-feed-css' href='https://www.mandatory.com/wp-content/plugins/wp-to-twitter/css/twitter-feed.css' type='text/css' media='all' /><link rel='stylesheet' id='main_stylesheet-css' href='https://www.mandatory.com/wp-content/plugins/spotim-comments/assets/stylesheets/main.css' type='text/css' media='all' /><link rel='stylesheet' id='NextGEN-css' href='https://www.mandatory.com/wp-content/plugins/nextgen-gallery/css/nggallery.css?ver=1.0.0' type='text/css' media='screen' /><link rel='stylesheet' id='wp-lightbox-2.min.css-css' href='https://www.mandatory.com/wp-content/plugins/wp-lightbox-2/styles/lightbox.min.css?ver=1.3.4' type='text/css' media='all' /><link rel='stylesheet' id='pb-main-styles-css' href='https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/css/dist/main.css?ver=1.1.13' type='text/css' media='screen' /><link rel='stylesheet' id='galleryview-css' href='https://www.mandatory.com/wp-content/plugins/nggGalleryview/css/jquery.pb-slideshow.css?ver=1.0' type='text/css' media='screen' /><script type='text/javascript' src='//ajax.googleapis.com/ajax/libs/jquery/1.7.1/jquery.min.js?ver=1.7.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/pb.core.js?ver=1.0.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/modernizr.js?ver=2.6.2'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/htmlParser.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/postscribe.min.js?ver=1.1.2'></script><script type='text/javascript' src='https://www.mandatory.com/libraries/pebblebed/js/gn_country.js'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/jquery.ba-resize.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/wp-evolve-gpt/js/pb.resize-iframe.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/wp-evolve-gpt/js/pb.gpt-builder.js?ver=2.0.1'></script><link rel='https://api.w.org/' href='https://www.mandatory.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mandatory.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://cdn2-www.mandatory.com/wp-includes/wlwmanifest.xml" /> <link rel='shortlink' href='https://www.mandatory.com/?p=1555788' /><link rel="alternate" type="application/json+oembed" href="https://www.mandatory.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mandatory.com%2Fculture%2F1555788-national-voter-registration-day-missy-modell-parody" /><link rel="alternate" type="text/xml+oembed" href="https://www.mandatory.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mandatory.com%2Fculture%2F1555788-national-voter-registration-day-missy-modell-parody&#038;format=xml" /><script>(function (win) {var PB = win.PB || {};PB.wpQueryVars = {query : 'a:10:{s:13:\"category_name\";s:7:\"culture\";s:3:\"tag\";s:0:\"\";s:1:\"p\";i:1555788;s:8:\"pagename\";s:0:\"\";s:9:\"post_type\";s:0:\"\";s:11:\"author_name\";s:0:\"\";s:8:\"taxonomy\";s:0:\"\";s:4:\"term\";s:0:\"\";s:4:\"home\";i:0;s:12:\"is_sponsored\";N;}'
};win.PB = PB;}(window));</script> <script type="text/javascript">(function () {window.siqConfig = {engineKey: "3de9c6be8827c86b076043ee4889d74a"
};window.siqConfig.baseUrl = "//pub.searchiq.co/";
var script = document.createElement("SCRIPT");script.src = window.siqConfig.baseUrl + 'js/container/siq-container-2.js?cb=' + (Math.floor(Math.random()*999999)) + '&engineKey=' + siqConfig.engineKey;script.id = "siq-container";document.getElementsByTagName("HEAD")[0].appendChild(script);})();</script><link rel="shortcut icon" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon.ico"><link rel="shortcut icon" sizes="16x16" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon-16x16.png"><link rel="shortcut icon" sizes="32x32" href="https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon-32x32.png"><link rel="shortcut icon" sizes="96x96" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/favicon-96x96.png"><link rel="apple-touch-icon" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon.png"><link rel="apple-touch-icon" sizes="57x57" href="https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-57x57.png"><link rel="apple-touch-icon" sizes="60x60" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-60x60.png"><link rel="apple-touch-icon" sizes="72x72" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-72x72.png"><link rel="apple-touch-icon" sizes="76x76" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-76x76.png"><link rel="apple-touch-icon" sizes="114x114" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-114x114.png"><link rel="apple-touch-icon" sizes="120x120" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-120x120.png"><link rel="apple-touch-icon" sizes="144x144" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-144x144.png"><link rel="apple-touch-icon" sizes="152x152" href="https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-152x152.png"><link rel="apple-touch-icon" sizes="180x180" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-180x180.png"><link rel="apple-touch-icon" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/apple-icon-precomposed.png"><meta name="msapplication-TileImage" content="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-70x70.png"><meta name="msapplication-TileImage" content="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-144x144.png"><meta name="msapplication-TileImage" content="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-150x150.png"><meta name="msapplication-TileImage" content="https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/ms-icon-310x310.png"><link rel="icon" type="image/png" sizes="36x36" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-36x36.png"><link rel="icon" type="image/png" sizes="48x48" href="https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-48x48.png"><link rel="icon" type="image/png" sizes="72x72" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-72x72.png"><link rel="icon" type="image/png" sizes="96x96" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-96x96.png"><link rel="icon" type="image/png" sizes="144x144" href="https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-144x144.png"><link rel="icon" type="image/png" sizes="192x192" href="https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/icons/android-icon-192x192.png"><script>(function (win) {var PB = win.PB || {};PB.WPQuery = {tagSlug      : '',authorId     : '',}}(window));</script><script type="text/javascript">var gptRefreshTimer = 30;</script><style>.menu-footer-container a{margin-bottom:0}</style><script type="text/javascript">function tkoSetting(){if(document.getElementsByClassName('ob-smartfeed-wrapper')[0] != undefined){document.getElementById('ob_holder').style.display = 'none';document.getElementsByClassName('ob-smartfeed-wrapper')[0].style.display = 'none';}}</script><script>window.onload = function(){if(document.querySelector(".col-right .gpt-ad") != null){var adDivTarget = document.querySelector(".col-right .gpt-ad").id;googletag.pubads().refresh([PB.gptAds[adDivTarget]]);}}</script><script type="text/javascript">var googletag = googletag || {};googletag.cmd = googletag.cmd || [];googletag.cmd.push(function() {googletag.pubads().setTargeting('ntvPlacement', '1111866');});</script><style>.container p{word-break:break-word}ol.index-menu li:before{font-size:20px;top:-3px}ol.index-menu li{padding:0;margin:0;height:auto;line-height:normal;min-height:34px}.article-content ol ol li:before{font-size:20px}table.exec-table{table-layout:fixed;width:100%}.exec-table tr td:nth-child(odd){background:gainsboro}.exec-table tr td:nth-child(even){background:#f7f7f7}.exec-table tr td{padding:5px}.table-c-1 tr td:nth-child(1){width:20%;min-width:150px}.table-c-1 tr td:nth-child(2){word-break:break-word}.table-c-2 tr td:nth-child(3),.table-c-2 tr td:nth-child(5){text-overflow:ellipsis;overflow:hidden}.fixed-table-overflow{overflow-x:auto}table.exec-table.table-c-1{min-width:800px}table.exec-table.table-c-2{min-width:800px}.article-content ol li ul li::before{display:none}</style><script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://screechingslip.com/v2jbcfYaGVljvQeyC4v9Jg6VS9DXxc7XlYhEl_bVryDBwYE-enRvbvg4Ive2FhaHYHQ",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(c,e,o,t,n){function r(o,t){(function n(){try{return 0<(localStorage.getItem("v4ac1eiZr0")||"").split(",")[4]}catch(o){}return!1})()&&(t=c[e].pubads())&&t.setTargeting("admiral-engaged","true")}(n=c[e]=c[e]||{}).cmd=n.cmd||[],typeof n.pubads===o?r():typeof n.cmd.unshift===o?n.cmd.unshift(r):n.cmd.push(r)})(window,"googletag","function");</script><meta name="google-site-verification" content="__d_ggPxMWKrfszXCobwb54AqmjfW-nX25MZUz1bpYM" /><script>var _comscore = _comscore || [];_comscore.push({ c1: "2", c2: "6036161" });(function() {var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
el.parentNode.insertBefore(s, el);})();</script><noscript> <img src="https://sb.scorecardresearch.com/p?c1=2&c2=6036161&cv=2.0&cj=1" /></noscript><style type="text/css">.girl-videos{display:none}@-moz-document url-prefix(){.post-listed-image img{position:relative;top:0;height:100%;object-fit:cover}.post-listed-image{overflow:hidden;position:relative;height:auto;padding:0;padding-top:0px}.home .post-listed:nth-of-type(5) .post-listed-image,.home .post-listed:nth-of-type(6) .post-listed-image,.home .post-listed:nth-of-type(12) .post-listed-image,.home .post-listed:nth-of-type(13) .post-listed-image{padding-top:0;width:50%}}.menu-wildaboutmovies a:before{background:#205b83}.leaderboard{z-index:9999999999}.single-listicle .top-logo{background:url(https://cdn1-www.mandatory.com/assets/uploads/2018/06/logo_ma.svg) no-repeat center center}@media only screen and (max-width:750px){.single-listicle .top-logo{background:url(https://cdn1-www.mandatory.com/assets/uploads/2018/06/logo_ma_small.svg) no-repeat center center}}span.title-companion-tag{background:#ccc;border:solid 1px #bbb;color:#555;text-transform:uppercase;height:27px;display:inline-block;font-size:11px;line-height:27px;padding:0 5px;margin:0}@media only screen and (min-width:860px){p.post-companion-logo{float:left;margin:-7px 8px 0 0;height:60px}}#billboard-close-btn svg{height:20px !important;width:20px !important}.category-girls a.nextpostslink,ul.girls-menu.girls-category-menu{display:none}.pbslideshow-navigation{border:0;top:40%;height:0;width:100%;position:absolute;background:0 0}.pbslideshow-navigation button:hover{background:none}#menu-social-media{display:none}</style><script>(function (s,o,n,a,r,i,z,e) {s['StackSonarObject']=r;s[r]=s[r]||function(){(s[r].q=s[r].q||[]).push(arguments)},s[r].l=1*new Date();i=o.createElement(n),z=o.getElementsByTagName(n)[0];i.async=1;i.src=a;z.parentNode.insertBefore(i,z)
})(window,document,'script','https://www.stack-sonar.com/ping.js','stackSonar');
stackSonar('stack-connect-wp', "0e132304-1922-4157-8953-c49efe882739");</script><link href="https://fonts.googleapis.com/css?family=Libre+Franklin:400,400i,700|Oswald:400,600,700" rel="stylesheet"></head><body class="post-template-default single single-post postid-1555788 single-format-standard single-listicle pb-no-header-scrollout" ><header class="header"><div class="header-container listicle-header-container"><button class="toggle-menu js-menu-btn"><span class="lines"></span></button><a href="/" class="top-logo">Logo</a><div class="listicle-title-counter"><progress id="main-progress" value="0"></progress><span id="js-image-counter" class="listicle-current-slide-counter">00/00</span><h2 class="listicle-post-title-header">The Perfect Carly Rae Jepson Parody to Celebrate National Voter Registration Day</h2></div></div><div class="header-container"><button class="toggle-menu js-menu-btn"><span class="lines"></span></button><a href="/" class="top-logo"><div id="custom_html-14" class="widget_text widget_custom_html"><span class="hidden">Logo &#8211; Original</span><div class="textwidget custom-html-widget"><img class="big no-lazy" src="https://cdn1-www.mandatory.com/assets/uploads/2018/06/logo_ma.svg" alt="Mandatory" /><img class="small no-lazy" src="https://cdn1-www.mandatory.com/assets/uploads/2018/06/logo_ma_small.svg" alt="Mandatory"/></div></div></a><div class="top-main-nav"><div class="menu-header-menu-container"><ul id="menu-header-menu" class="menu"><li id="menu-item-1451263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1451263"><a href="https://www.mandatory.com/fun" >Fun</a></li><li id="menu-item-1451261" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1451261"><a href="https://www.mandatory.com/culture" >Culture</a></li><li id="menu-item-1451269" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1451269"><a href="https://www.mandatory.com/living" >Living</a></li><li id="menu-item-1451267" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1451267"><a href="https://www.mandatory.com/inspire" >Inspire</a></li><li id="menu-item-1451271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1451271"><a href="https://www.mandatory.com/the-world" >The World</a></li><li id="menu-item-1550030" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1550030"><a href="https://www.mandatory.com/shop" >Shop</a></li><li id="menu-item-1551037" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1551037"><a href="https://www.mandatory.com/deals" >Deals</a></li></ul></div></div><div class="top-social-menu js-social"><div class="ad-choices-logo-navbar"><div id="custom_html-13" class="widget_text widget_custom_html promo pb-slideshow-ad-container"><span class="hidden">AdChoices logo</span><div class="textwidget custom-html-widget"><div data-glade data-ad-unit-path="/4403/cr/mandatory" height="13" width="70"></div><script async='async' src='https://securepubads.g.doubleclick.net/static/glade.js'></script></div></div></div><div class="menu-social-media-container"><ul id="menu-social-media" class="menu"><li id="menu-item-1398188" class="menu-fb menu-item menu-item-type-custom menu-item-object-custom menu-item-1398188"><a target="_blank" href="https://www.facebook.com/MANDATORY/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.facebook.com']);">Facebook</a></li><li id="menu-item-1398189" class="menu-tw menu-item menu-item-type-custom menu-item-object-custom menu-item-1398189"><a target="_blank" href="https://twitter.com/Mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://twitter.com']);">Twitter</a></li><li id="menu-item-1398190" class="menu-in menu-item menu-item-type-custom menu-item-object-custom menu-item-1398190"><a target="_blank" href="https://www.instagram.com/mandatorydotcom/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.instagram.com']);">Instagram</a></li><li id="menu-item-1407431" class="menu-ac menu-item menu-item-type-custom menu-item-object-custom menu-item-1407431"><a href="http://www.mandatory.com/cookies" ></a></li></ul></div><div class="toggle-social js-social-btn"><div class="toggle-dots"></div></div></div><div class="top-search js-search-btn"><svg width="18" height="18" xmlns="http://www.w3.org/2000/svg">><path id="svg_2" d="m15.707,14.293l-3.961,-3.968c0.785,-1.074 1.254,-2.393 1.254,-3.826c0,-3.59 -2.911,-6.499 -6.5,-6.499c-3.59,0 -6.5,2.909 -6.5,6.499s2.91,6.5 6.5,6.5c1.436,0 2.757,-0.471 3.833,-1.259l3.959,3.966c0.391,0.391 1.023,0.391 1.414,0s0.391,-1.023 0.001,-1.413zm-9.207,-3.294c-2.485,0 -4.5,-2.015 -4.5,-4.5s2.015,-4.5 4.5,-4.5c2.486,0 4.5,2.015 4.5,4.5s-2.014,4.5 -4.5,4.5z" fill="#FFF"></path></svg></div></div></header><div class="menu-sidebar js-menu"><div class="sidebar-nav-main"><h3>Navigation</h3><div class="menu-header-menu-container"><ul id="menu-header-menu-1" class="js-collapse-menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1451263"><a href="https://www.mandatory.com/fun" >Fun</a><ul class="sub-menu"><li id="menu-item-1525115" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525115"><a href="https://www.mandatory.com/fun/funny-photos" >Funny Photos</a></li><li id="menu-item-1525117" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525117"><a href="https://www.mandatory.com/fun/weird-news" >Weird News</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-1451261"><a href="https://www.mandatory.com/culture" >Culture</a><ul class="sub-menu"><li id="menu-item-1525107" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1525107"><a href="https://www.mandatory.com/culture/entertainment" >Entertainment</a></li><li id="menu-item-1525109" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525109"><a href="https://www.mandatory.com/culture/gaming" >Gaming</a></li><li id="menu-item-1525111" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525111"><a href="https://www.mandatory.com/culture/music" >Music</a></li><li id="menu-item-1525113" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525113"><a href="https://www.mandatory.com/culture/sports" >Sports</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1451269"><a href="https://www.mandatory.com/living" >Living</a><ul class="sub-menu"><li id="menu-item-1525119" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525119"><a href="https://www.mandatory.com/living/cannabis" >Cannabis</a></li><li id="menu-item-1525121" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525121"><a href="https://www.mandatory.com/living/food-and-drink" >Food &#038; Drink</a></li><li id="menu-item-1525123" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525123"><a href="https://www.mandatory.com/living/gear" >Gear</a></li><li id="menu-item-1525125" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525125"><a href="https://www.mandatory.com/living/life-hacks" >Life Hacks</a></li><li id="menu-item-1525127" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525127"><a href="https://www.mandatory.com/living/sex-and-relationships" >Sex and Relationships</a></li><li id="menu-item-1525129" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1525129"><a href="https://www.mandatory.com/living/style" >Style</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1451267"><a href="https://www.mandatory.com/inspire" >Inspire</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1451271"><a href="https://www.mandatory.com/the-world" >The World</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1550030"><a href="https://www.mandatory.com/shop" >Shop</a><ul class="sub-menu"><li id="menu-item-1550033" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1550033"><a href="https://evolve-media-llc.myshopify.com/collections/mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://evolve-media-llc.myshopify.com']);">Merch</a></li><li id="menu-item-1550032" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1550032"><a href="https://www.mandatory.com/deals" >Deals</a></li><li id="menu-item-1550031" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1550031"><a href="https://www.mandatory.com/shop" >Shop</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1551037"><a href="https://www.mandatory.com/deals" >Deals</a></li></ul></div></div><div class="sidebar-nav-sites"><h3>More from our channels</h3><div class="menu-our-channels-container"><ul id="menu-our-channels" class="menu"><li id="menu-item-1398179" class="menu-cs menu-item menu-item-type-custom menu-item-object-custom menu-item-1398179"><a href="http://www.comingsoon.net/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.comingsoon.net']);">ComingSoon</a></li><li id="menu-item-1398180" class="menu-gr menu-item menu-item-type-custom menu-item-object-custom menu-item-1398180"><a href="http://www.gamerevolution.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.gamerevolution.com']);">GameRevolution</a></li><li id="menu-item-1398181" class="menu-sd menu-item menu-item-type-custom menu-item-object-custom menu-item-1398181"><a href="http://www.sherdog.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.sherdog.com']);">Sherdog</a></li><li id="menu-item-1398182" class="menu-wz menu-item menu-item-type-custom menu-item-object-custom menu-item-1398182"><a href="http://www.mandatory.com/wrestlezone/" >WrestleZone</a></li><li id="menu-item-1398183" class="menu-shh menu-item menu-item-type-custom menu-item-object-custom menu-item-1398183"><a href="http://www.superherohype.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.superherohype.com']);">SuperHeroHype</a></li><li id="menu-item-1398184" class="menu-psls menu-item menu-item-type-custom menu-item-object-custom menu-item-1398184"><a href="http://www.playstationlifestyle.net/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.playstationlifestyle.net']);">PlayStation LifeStyle</a></li><li id="menu-item-1549451" class="menu-mf menu-item menu-item-type-custom menu-item-object-custom menu-item-1549451"><a href="https://musicfeeds.com.au/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://musicfeeds.com.au']);">MusicFeeds</a></li><li id="menu-item-1550245" class="menu-lo menu-item menu-item-type-custom menu-item-object-custom menu-item-1550245"><a href="https://www.liveoutdoors.com/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.liveoutdoors.com']);">LiveOutdoors</a></li></ul></div></div><div class="sidebar-nav-social"><h3>Follow us on Social Media</h3><div class="menu-social-media-container"><ul id="menu-social-media-1" class="menu"><li class="menu-fb menu-item menu-item-type-custom menu-item-object-custom menu-item-1398188"><a target="_blank" href="https://www.facebook.com/MANDATORY/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.facebook.com']);">Facebook</a></li><li class="menu-tw menu-item menu-item-type-custom menu-item-object-custom menu-item-1398189"><a target="_blank" href="https://twitter.com/Mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://twitter.com']);">Twitter</a></li><li class="menu-in menu-item menu-item-type-custom menu-item-object-custom menu-item-1398190"><a target="_blank" href="https://www.instagram.com/mandatorydotcom/" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.instagram.com']);">Instagram</a></li><li class="menu-ac menu-item menu-item-type-custom menu-item-object-custom menu-item-1407431"><a href="http://www.mandatory.com/cookies" ></a></li></ul></div></div></div><div class="search-form js-search"><form role="search" method="get" action="https://www.mandatory.com/search"><div class="search-wrap"><input type="search" class="search-form-input js-search-form-input" placeholder="Search…" name="q" value="" /></div></form></div><div class="container"><div class="leaderboard js-listicle-top js-leaderboard"><div id="billboard-close-btn" class="billboard-close-btn"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 455.992 455.992" style="height: 20px; width: 20px;"> <g fill="#010002"> <path d="M227.996 0C102.081 0 0 102.081 0 227.996c0 125.945 102.081 227.996 227.996 227.996 125.945 0 227.996-102.051 227.996-227.996C455.992 102.081 353.941 0 227.996 0zm0 425.593c-108.952 0-197.597-88.645-197.597-197.597S119.044 30.399 227.996 30.399s197.597 88.645 197.597 197.597-88.645 197.597-197.597 197.597z" /> <path d="M312.142 122.358l-83.538 83.568-74.965-83.568c-5.928-5.928-15.565-5.928-21.492 0-5.928 5.928-5.928 15.565 0 21.492l74.965 83.568-84.723 84.723c-5.928 5.928-5.928 15.595 0 21.492 5.928 5.928 15.565 5.928 21.492 0l83.568-83.538 74.965 83.538c5.897 5.928 15.565 5.928 21.462 0 5.928-5.898 5.928-15.565 0-21.492l-74.995-83.538 84.723-84.754c5.928-5.928 5.928-15.565 0-21.492-5.928-5.927-15.534-5.927-21.462.001z" /> </g></svg></div><div id="evolve_ad_gpt_widget-43" class="widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="culture_970x250x970x90x728x90_a_slot3_1600808751"
data-id="culture_970x250x970x90x728x90_a_slot3_1600808751"
data-offset="300"
class="gpt-ad"><script type='text/javascript'>PB        = PB || {};PB.gptStandAlone = PB.gptStandAlone || {};PB.gptAutoRefresh = PB.gptAutoRefresh || {'gptAds':[], 'gptStandAlone':[]};admiralCookie = readAdmiralCookie();googletag.cmd.push(function() {var standAloneSizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([750, 0], []).addSize([980, 0], [[970, 250],[970, 90],[728, 90]]).build();PB.gptStandAlone['culture_970x250x970x90x728x90_a_slot3_1600808751'] = googletag.defineSlot('/4403/cr/mandatory/culture', [[970, 250],[970, 90],[728, 90]], 'culture_970x250x970x90x728x90_a_slot3_1600808751')
.defineSizeMapping(standAloneSizeMapping).addService(googletag.pubads())
.setTargeting('pos', 'A').setTargeting('ct', 'article').setTargeting('ci', '1555788').setTargeting('content_detail', '4').setTargeting('kw', '2020,2020-democrats,2020-election,announcement,best-of,biden,biden-harris,campaign,candidates,carly-rae-jepson,culture,democrat,donald-trump,election,entertainment,fails,fake-news,fun,funniest,funniest-of-the-week,funny,funny-news,haha,joe-biden,kamala-harris,latest-news,lol,missy-modell,national-voter-registration-day,news,policy,political-news,political-satire,politicians,politics,president,presidential,presidential-election,presidential-race,register,register-to-vote,ridiculous-news,running-mate,satire,senator,social-media,strange-news,todays-funny-photos,trump,vice-president,video,videos,vote,voter-registration,vp,weird-news,listicle').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.enableServices();googletag.display('culture_970x250x970x90x728x90_a_slot3_1600808751');if (admiralCookie === null || admiralCookie['val'] === 'false') {googletag.pubads().refresh([PB.gptStandAlone['culture_970x250x970x90x728x90_a_slot3_1600808751']]);}});</script></div></div><div id="evolve_ad_gpt_widget-44" class="widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="culture_728x90_a_slot4_1600808751"
data-id="culture_728x90_a_slot4_1600808751"
data-offset="300"
class="gpt-ad"><script type='text/javascript'>PB        = PB || {};PB.gptStandAlone = PB.gptStandAlone || {};PB.gptAutoRefresh = PB.gptAutoRefresh || {'gptAds':[], 'gptStandAlone':[]};admiralCookie = readAdmiralCookie();googletag.cmd.push(function() {var standAloneSizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([750, 0], [[728, 90]]).addSize([980, 0], []).build();PB.gptStandAlone['culture_728x90_a_slot4_1600808751'] = googletag.defineSlot('/4403/cr/mandatory/culture', [[728, 90]], 'culture_728x90_a_slot4_1600808751')
.defineSizeMapping(standAloneSizeMapping).addService(googletag.pubads())
.setTargeting('pos', 'A').setTargeting('ct', 'article').setTargeting('ci', '1555788').setTargeting('content_detail', '4').setTargeting('kw', '2020,2020-democrats,2020-election,announcement,best-of,biden,biden-harris,campaign,candidates,carly-rae-jepson,culture,democrat,donald-trump,election,entertainment,fails,fake-news,fun,funniest,funniest-of-the-week,funny,funny-news,haha,joe-biden,kamala-harris,latest-news,lol,missy-modell,national-voter-registration-day,news,policy,political-news,political-satire,politicians,politics,president,presidential,presidential-election,presidential-race,register,register-to-vote,ridiculous-news,running-mate,satire,senator,social-media,strange-news,todays-funny-photos,trump,vice-president,video,videos,vote,voter-registration,vp,weird-news,listicle').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.enableServices();googletag.display('culture_728x90_a_slot4_1600808751');if (admiralCookie === null || admiralCookie['val'] === 'false') {googletag.pubads().refresh([PB.gptStandAlone['culture_728x90_a_slot4_1600808751']]);}});</script></div></div><div id="evolve_ad_gpt_widget-45" class="widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="culture_320x150x320x100x320x50x300x50_a_slot5_1600808751"
data-id="culture_320x150x320x100x320x50x300x50_a_slot5_1600808751"
data-offset="300"
class="gpt-ad"><script type='text/javascript'>PB        = PB || {};PB.gptStandAlone = PB.gptStandAlone || {};PB.gptAutoRefresh = PB.gptAutoRefresh || {'gptAds':[], 'gptStandAlone':[]};admiralCookie = readAdmiralCookie();googletag.cmd.push(function() {var standAloneSizeMapping = googletag.sizeMapping().addSize([0, 0], [[320, 150],[320, 100],[320, 50],[300, 50]]).addSize([750, 0], []).addSize([980, 0], []).build();PB.gptStandAlone['culture_320x150x320x100x320x50x300x50_a_slot5_1600808751'] = googletag.defineSlot('/4403/cr/mandatory/culture', [[320, 150],[320, 100],[320, 50],[300, 50]], 'culture_320x150x320x100x320x50x300x50_a_slot5_1600808751')
.defineSizeMapping(standAloneSizeMapping).addService(googletag.pubads())
.setTargeting('pos', 'A').setTargeting('ct', 'article').setTargeting('ci', '1555788').setTargeting('content_detail', '4').setTargeting('kw', '2020,2020-democrats,2020-election,announcement,best-of,biden,biden-harris,campaign,candidates,carly-rae-jepson,culture,democrat,donald-trump,election,entertainment,fails,fake-news,fun,funniest,funniest-of-the-week,funny,funny-news,haha,joe-biden,kamala-harris,latest-news,lol,missy-modell,national-voter-registration-day,news,policy,political-news,political-satire,politicians,politics,president,presidential,presidential-election,presidential-race,register,register-to-vote,ridiculous-news,running-mate,satire,senator,social-media,strange-news,todays-funny-photos,trump,vice-president,video,videos,vote,voter-registration,vp,weird-news,listicle').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.enableServices();googletag.display('culture_320x150x320x100x320x50x300x50_a_slot5_1600808751');if (admiralCookie === null || admiralCookie['val'] === 'false') {googletag.pubads().refresh([PB.gptStandAlone['culture_320x150x320x100x320x50x300x50_a_slot5_1600808751']]);}});</script></div></div></div><div class="col-left listicle-format"><article class="post-content"><div class="breadcrumb"><div class="breadcrumb-category"><a href="https://www.mandatory.com/culture" rel="category tag">Culture</a> / <a href="https://www.mandatory.com/culture/entertainment" rel="subcategory tag">Entertainment</a></div><div class="breadcrumb-social"><div class="pw-server-widget" data-id="wid-9c0metel" data-via="Mandatory"></div></div></div><div class="featured-image"><figure><img width="600" height="335" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn2-www.mandatory.com/assets/uploads/2020/09/Vote-e1600800217285.jpg" class="lazy lazy-hidden attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="voter" /><noscript><img width="600" height="335" src="https://cdn2-www.mandatory.com/assets/uploads/2020/09/Vote-e1600800217285.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="voter" /></noscript></figure></div><h1>The Perfect Carly Rae Jepson Parody to Celebrate National Voter Registration Day</h1><span class="share-tools"><div class="a2a_kit a2a_kit_size_32 a2a_default_style" data-a2a-url="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody" data-a2a-title="The Perfect Carly Rae Jepson Parody to Celebrate National Voter Registration Day"> <a class="a2a_button_facebook"></a> <a class="a2a_button_twitter"></a> <a class="a2a_button_reddit"></a> <a class="a2a_button_pinterest"></a> <a class="a2a_button_whatsapp"></a> <a class="a2a_button_email"></a></div><script async src="https://static.addtoany.com/menu/page.js"></script></span><div class="author-date">by <a href="https://www.mandatory.com/author/mandatory-editors">Mandatory Editors</a> <time datetime="2020-09-22">Sep 22nd, 2020</time></div><div style="position: relative; overflow: hidden; padding-top: 56.25%;"><iframe id="bamf-vp_1585937093_1744765" style="position: absolute; top: 0px; left: 0px; width: 100%; height: 100%; border: 0px; overflow: hidden;" src="https://play.springboardplatform.com?autoplay=true&amp;controls=true&amp;loop=false&amp;muted=true&amp;iu=%2F4403%2Fcr%2Fmandatory%2Fvast&amp;cust_params=kw%3Dvast&amp;width=560&amp;height=315&amp;site_id=5503&amp;video_id=1744765&amp;lazy=false&amp;debug=false" name="bamf-vp_1585937093_1744765" frameborder="0" scrolling="no" allowfullscreen="allowfullscreen"></iframe><script id="bamf-vp_1585937093_1744765-script" src="https://play.springboardplatform.com/loader.min.js?iframeId=bamf-vp_1585937093_1744765&amp;lazy=false&amp;debug=false&amp;viewability=true"></script></div><p>It&rsquo;s <strong>National Voter Registration Day</strong>, and what better way to celebrate (and motivate) voters than a new <strong>Missy Modell</strong> <a href="https://www.mandatory.com/culture/1553416-destinys-child-survivor-parody-gives-viral-glimpse-at-the-badassery-of-ruth-bader-ginsburg" target="_blank" rel="noopener">parody video</a>? The <a href="https://www.mandatory.com/culture/1551924-missy-modell-goes-viral-again-with-miley-cyrus-voter-suppression-parody" target="_blank" rel="noopener">viral Instagrammer</a> teamed up with <a href="https://defeatbytweet.org/" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://defeatbytweet.org']);" target="_blank" rel="noopener">Defeat By Tweet</a>, the platform transforming Trump&rsquo;s tweets into donations for racial justice, to create an inspiring song set to the tune of Carly Rae Jepsen&rsquo;s poppy earworm &ldquo;Call Me Maybe.&rdquo;</p><blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 540px; min-width: 326px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-permalink="https://www.instagram.com/tv/CFb659EjRJP/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12"><div style="padding: 16px;"><p>&nbsp;</p><div style="display: flex; flex-direction: row; align-items: center;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div><div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div><div style="background-color: #f4f4f4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div><div style="display: block; height: 50px; margin: 0 auto 12px; width: 50px;"></div><div style="padding-top: 8px;"><div style="color: #3897f0; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: 550; line-height: 18px;">View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div><div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div><div style="background-color: #f4f4f4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div><div style="background-color: #f4f4f4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"><div style="background-color: #f4f4f4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div><div style="width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg);"></div></div><div style="margin-left: auto;"><div style="width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div><div style="background-color: #f4f4f4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div><div style="width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div><p>&nbsp;</p><p style="margin: 8px 0 0 0; padding: 0 4px;"><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/tv/CFb659EjRJP/?utm_source=ig_embed&amp;utm_campaign=loading" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://www.instagram.com']);" target="_blank" rel="noopener">It&rsquo;s National Voter Registration Day! I partnered with my friends at @defeatbytweet to share why we absolutely NEED to vote in this election. There&rsquo;s a frightening amount at stake. 100 million people didn&rsquo;t vote in 2016. Let&rsquo;s not make that mistake again, k? Make sure you&rsquo;re registered and tell all your &amp; family friends to do it too! Video edited by @flackncoke Vocal mix by @mattbeilis Written with @scottsimonsmusic #defeatbytweet #vote #parody #nationalvoterregistrationday #election2020 #election #vote2020</a></p><p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by <a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px;" href="https://www.instagram.com/missymodell/?utm_source=ig_embed&amp;utm_campaign=loading" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://www.instagram.com']);" target="_blank" rel="noopener"> Missy Modell</a> (@missymodell) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2020-09-22T11:00:07+00:00">Sep 22, 2020 at 4:00am PDT</time></p></div></blockquote><p><script async="" src="//www.instagram.com/embed.js"></script></p><div class="pb-in-article-content"><div id="evolve_ad_gpt_widget-48" class="widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="culture_300x250_p_slot8_1600808751"
data-id="culture_300x250_p_slot8_1600808751"
data-offset="300"
class="gpt-ad js-inview"><script type='text/javascript'>PB        = PB || {};PB.gptStandAlone = PB.gptStandAlone || {};PB.gptAutoRefresh = PB.gptAutoRefresh || {'gptAds':[], 'gptStandAlone':[]};admiralCookie = readAdmiralCookie();googletag.cmd.push(function() {var standAloneSizeMapping = googletag.sizeMapping().addSize([0, 0], []).addSize([750, 0], [[300, 250]]).addSize([980, 0], [[300, 250]]).build();PB.gptStandAlone['culture_300x250_p_slot8_1600808751'] = googletag.defineSlot('/4403/cr/mandatory/culture', [[300, 250]], 'culture_300x250_p_slot8_1600808751')
.defineSizeMapping(standAloneSizeMapping).addService(googletag.pubads())
.setTargeting('pos', 'P').setTargeting('ct', 'article').setTargeting('ci', '1555788').setTargeting('content_detail', '4').setTargeting('kw', '2020,2020-democrats,2020-election,announcement,best-of,biden,biden-harris,campaign,candidates,carly-rae-jepson,culture,democrat,donald-trump,election,entertainment,fails,fake-news,fun,funniest,funniest-of-the-week,funny,funny-news,haha,joe-biden,kamala-harris,latest-news,lol,missy-modell,national-voter-registration-day,news,policy,political-news,political-satire,politicians,politics,president,presidential,presidential-election,presidential-race,register,register-to-vote,ridiculous-news,running-mate,satire,senator,social-media,strange-news,todays-funny-photos,trump,vice-president,video,videos,vote,voter-registration,vp,weird-news,listicle,in-article').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.enableServices();googletag.display('culture_300x250_p_slot8_1600808751');if (admiralCookie === null || admiralCookie['val'] === 'false') {googletag.pubads().refresh([PB.gptStandAlone['culture_300x250_p_slot8_1600808751']]);}});</script></div></div><div id="evolve_ad_gpt_widget-31" class="widget_evolve_ad_gpt_widget promo pb-slideshow-ad-container"><div id="pb_prebidjs_300x250_a_1600808751"
data-id="pb_prebidjs_300x250_a_1600808751"
data-offset="300"
class="gpt-ad js-inview"><script type='text/javascript'>PB        = PB || {};PB.gptStandAlone = PB.gptStandAlone || {};PB.gptAutoRefresh = PB.gptAutoRefresh || {'gptAds':[], 'gptStandAlone':[]};admiralCookie = readAdmiralCookie();googletag.cmd.push(function() {var standAloneSizeMapping = googletag.sizeMapping().addSize([0, 0], [[300, 250]]).addSize([750, 0], []).addSize([980, 0], []).build();PB.gptStandAlone['pb_prebidjs_300x250_a_1600808751'] = googletag.defineSlot('/4403/cr/mandatory/culture', [[300, 250]], 'pb_prebidjs_300x250_a_1600808751')
.defineSizeMapping(standAloneSizeMapping).addService(googletag.pubads())
.setTargeting('pos', 'A').setTargeting('ct', 'article').setTargeting('ci', '1555788').setTargeting('content_detail', '4').setTargeting('kw', '2020,2020-democrats,2020-election,announcement,best-of,biden,biden-harris,campaign,candidates,carly-rae-jepson,culture,democrat,donald-trump,election,entertainment,fails,fake-news,fun,funniest,funniest-of-the-week,funny,funny-news,haha,joe-biden,kamala-harris,latest-news,lol,missy-modell,national-voter-registration-day,news,policy,political-news,political-satire,politicians,politics,president,presidential,presidential-election,presidential-race,register,register-to-vote,ridiculous-news,running-mate,satire,senator,social-media,strange-news,todays-funny-photos,trump,vice-president,video,videos,vote,voter-registration,vp,weird-news,listicle,in-article-mobile').setTargeting('coppa', '0').setTargeting('site', 'mandatory');googletag.enableServices();googletag.display('pb_prebidjs_300x250_a_1600808751');if (admiralCookie === null || admiralCookie['val'] === 'false') {googletag.pubads().refresh([PB.gptStandAlone['pb_prebidjs_300x250_a_1600808751']]);}});</script></div></div></div><p>&ldquo;Feels like we&rsquo;re living in hell / Is this year real? I can&rsquo;t tell / This is my cry out for help / Save our democracy!&rdquo; Modell sings at the start of the video. She then tears into Trump&rsquo;s pathological lying, affinity for fake news, COVID conspiracies, climate change denial, and Twitter rants, just to name a few awful things about him.</p><p>As Modell reminds viewers, you don&rsquo;t have to wait until November to start defeating Trump. You can register to vote now, and, in some states, cast your vote by mail already, too!</p><p>Voting is always important because it helps preserve our democracy, but it&rsquo;s especially crucial this year so we can get the big dumb Cheeto in Chief out of office.</p><p>&ldquo;100 million people didn&rsquo;t vote in 2016,&rdquo; Modell points out in the caption. &ldquo;Let&rsquo;s not make that mistake again, k? Make sure you&rsquo;re registered and tell all your &amp; family friends to do it too!&rdquo;</p><h6><span style="color: #999999;"><em>Cover Photo: @missymodell (Instagram)</em></span></h6><h2 style="text-align: center;"><span style="color: #999999;">Mandatory Voting:</span> <a href="https://www.mandatory.com/culture/1553821-mandatory-voting-12-simple-reasons-to-be-pro-joe-and-against-don-the-con" target="_blank" rel="noopener"><span style="color: #ff0000;">12 Simple Reasons to Be Pro Joe (And Against Don the Con)</span></a></h2><h2>MORE NEWS:</h2> <section data-total-images="12" id="pb-listicle-gallery" class="listicle-images-container crave" data-gallery-id="35317"><ul><li id="pb_listicle_image_1" class="listicle-item js-inview-listicle" data-current-image="1"><header class="listicle-item-header"><span class="pbslideshow-num-images">1/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-1133760069-e1592573004761.jpg" alt="Men’s Beards May Have Evolved to Sustain Punches to the Head, Random Study Suggests Scientists Are Running Out of Things to Study" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-1133760069-e1592573004761.jpg" alt="Men’s Beards May Have Evolved to Sustain Punches to the Head, Random Study Suggests Scientists Are Running Out of Things to Study" width="600" height="400"/></noscript><div class="listicle-description"><h2>Men’s Beards May Have Evolved to Sustain Punches to the Head, Random Study Suggests Scientists Are Running Out of Things to Study</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1549706-mens-beards-may-have-evolved-to-sustain-punches-to-the-head" >click here. </a></p><h6><span style="color: #999999;"><em>Photo Credit: max-kegfire (Getty Images)</em></span></h6></div></li><li id="pb_listicle_image_2" class="listicle-item js-inview-listicle" data-current-image="2"><header class="listicle-item-header"><span class="pbslideshow-num-images">2/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-1179531317-e1594912399748.jpg" alt="Louisiana Man Puts the ‘Ass’ in Bass Pro Shop by Swimming in Fish Tank" width="600" height="338"/><noscript><img class="listicle-img" src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-1179531317-e1594912399748.jpg" alt="Louisiana Man Puts the ‘Ass’ in Bass Pro Shop by Swimming in Fish Tank" width="600" height="338"/></noscript><div class="listicle-description"><h2>Louisiana Man Puts the ‘Ass’ in Bass Pro Shop by Swimming in Fish Tank</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1551402-louisiana-man-puts-the-ass-in-bass-pro-shop-by-swimming-in-fish-tank" >click here.</a></p><h6><span style="color: #999999;"><em>Photo Credit: Niklas Jourdan / EyeEm (Getty Images)</em></span></h6></div></li><li class="listicle-item listicle-ad js-listicle-ad"> </li><li id="pb_listicle_image_3" class="listicle-item js-inview-listicle" data-current-image="3"><header class="listicle-item-header"><span class="pbslideshow-num-images">3/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-1240562264-e1592140067947.jpg" alt="San Jose Police Fire Rubber Bullets at Their Own Trainer, Rupturing His Testicle (That’s Nuts)" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-1240562264-e1592140067947.jpg" alt="San Jose Police Fire Rubber Bullets at Their Own Trainer, Rupturing His Testicle (That’s Nuts)" width="600" height="400"/></noscript><div class="listicle-description"><h2>San Jose Police Fire Rubber Bullets at Their Own Trainer, Rupturing His Testicle (That’s Nuts)</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1549389-san-jose-police-fire-rubber-bullets-at-their-own-trainer" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: MediaNews Group/The Mercury News via Getty Images / Contributor (Getty Images)</span></em></h6></div></li><li id="pb_listicle_image_4" class="listicle-item js-inview-listicle" data-current-image="4"><header class="listicle-item-header"><span class="pbslideshow-num-images">4/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-731844923-e1594927644680.jpg" alt="Apple Delays iPhone 12 Release, Consumers Expected to Just Use Phone They’ve Had a Whole Year Already" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/gettyimages-731844923-e1594927644680.jpg" alt="Apple Delays iPhone 12 Release, Consumers Expected to Just Use Phone They’ve Had a Whole Year Already" width="600" height="400"/></noscript><div class="listicle-description"><h2>Apple Delays iPhone 12 Release, Consumers Expected to Just Use Phone They’ve Had a Whole Year Already</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1551447-apple-delays-iphone-12-release" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: Adam Kuylenstierna / EyeEm (Getty Images)</span></em></h6></div></li><li class="listicle-item listicle-ad js-listicle-ad"> </li><li id="pb_listicle_image_5" class="listicle-item js-inview-listicle" data-current-image="5"><header class="listicle-item-header"><span class="pbslideshow-num-images">5/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn2-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/ivanka-e1594845117425.jpg" alt="Ivanka Trump Tells Unemployed Americans to ‘Find Something New,’ Which Is Precisely What We Wish Her Whole Family Would Do" width="599" height="399"/><noscript><img class="listicle-img" src="https://cdn2-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/ivanka-e1594845117425.jpg" alt="Ivanka Trump Tells Unemployed Americans to ‘Find Something New,’ Which Is Precisely What We Wish Her Whole Family Would Do" width="599" height="399"/></noscript><div class="listicle-description"><h2>Ivanka Trump Tells Unemployed Americans to ‘Find Something New,’ Which Is Precisely What We Wish Her Whole Family Would Do</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1551345-ivanka-tells-unemployed-americans-to-find-something-new-which-is-precisely-what-we-wish-her-whole-family-would-do" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: Alex Wong / Staff (Getty Images)</span></em></h6></div></li><li id="pb_listicle_image_6" class="listicle-item js-inview-listicle" data-current-image="6"><header class="listicle-item-header"><span class="pbslideshow-num-images">6/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/kanye-e1595024077654.jpg" alt="Dumb as Rocks: Kanye West Photoshops His Face Onto Mount Rushmore" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/kanye-e1595024077654.jpg" alt="Dumb as Rocks: Kanye West Photoshops His Face Onto Mount Rushmore" width="600" height="400"/></noscript><div class="listicle-description"><h2>Dumb as Rocks: Kanye West Photoshops His Face Onto Mount Rushmore</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1551548-kanye-west-photoshops-his-face-on-mount-rushmore" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: @kanyewest (Twitter)</span></em></h6></div></li><li class="listicle-item listicle-ad js-listicle-ad"> </li><li id="pb_listicle_image_7" class="listicle-item js-inview-listicle" data-current-image="7"><header class="listicle-item-header"><span class="pbslideshow-num-images">7/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/screen-shot-2020-07-15-at-11-43-44-pm.png" alt="The Internet Had Its Phallic Way With Ivanka Trump Modeling Goya Beans, Hilarious Tweets Ensued" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/screen-shot-2020-07-15-at-11-43-44-pm.png" alt="The Internet Had Its Phallic Way With Ivanka Trump Modeling Goya Beans, Hilarious Tweets Ensued" width="600" height="400"/></noscript><div class="listicle-description"><h2>The Internet Had Its Phallic Way With Ivanka Trump Modeling Goya Beans, Hilarious Tweets Ensued</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1551365-twitters-funniest-reaction-to-ivanka-trumps-law-breaking-goya-bean-endorsement" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: @SsnarkIsMyGame (Twitter)</span></em></h6></div></li><li id="pb_listicle_image_8" class="listicle-item js-inview-listicle" data-current-image="8"><header class="listicle-item-header"><span class="pbslideshow-num-images">8/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn2-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-100.jpg" alt="Rudy Giuliani Calls NYPD After Being Pranked by Sacha Baron Cohen, Can Only Take a Joke if it Becomes President" width="600" height="399"/><noscript><img class="listicle-img" src="https://cdn2-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-100.jpg" alt="Rudy Giuliani Calls NYPD After Being Pranked by Sacha Baron Cohen, Can Only Take a Joke if it Becomes President" width="600" height="399"/></noscript><div class="listicle-description"><h2>Rudy Giuliani Calls NYPD After Being Pranked by Sacha Baron Cohen, Can Only Take a Joke if it Becomes President</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1550963-rudy-giuliani-calls-nypd-after-being-pranked-by-sacha-baron-cohen" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: The Hollywood Reporter, via Getty Images</span></em></h6></div></li><li class="listicle-item listicle-ad js-listicle-ad"> </li><li id="pb_listicle_image_9" class="listicle-item js-inview-listicle" data-current-image="9"><header class="listicle-item-header"><span class="pbslideshow-num-images">9/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-2020-07-11t135216-043.jpg" alt="Badass Mother Who Wore Face Mask Through 38-Hour Labor Says ‘If I Can, So Can You’" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn3-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-2020-07-11t135216-043.jpg" alt="Badass Mother Who Wore Face Mask Through 38-Hour Labor Says ‘If I Can, So Can You’" width="600" height="400"/></noscript><div class="listicle-description"><h2>Badass Mother Who Wore Face Mask Through 38-Hour Labor Says ‘If I Can, So Can You’</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1550967-badass-mother-who-wore-facemask-through-38-hour-labor-says-if-i-can-so-can-you" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: Jai Kershner</span></em></h6></div></li><li id="pb_listicle_image_10" class="listicle-item js-inview-listicle" data-current-image="10"><header class="listicle-item-header"><span class="pbslideshow-num-images">10/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-2020-07-16t011908-876.jpg" alt="Aww Nuts: Squirrel in Colorado Tests Positive for Bubonic Plague Because 2020" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-2020-07-16t011908-876.jpg" alt="Aww Nuts: Squirrel in Colorado Tests Positive for Bubonic Plague Because 2020" width="600" height="400"/></noscript><div class="listicle-description"><h2>Aww Nuts: Squirrel in Colorado Tests Positive for Bubonic Plague Because 2020</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1551406-aww-nuts-squirrel-in-colorado-tests-positive-for-bubonic-plague-because-2020" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: Picture Alliance via Getty Images</span></em></h6></div></li><li class="listicle-item listicle-ad js-listicle-ad"> </li><li id="pb_listicle_image_11" class="listicle-item js-inview-listicle" data-current-image="11"><header class="listicle-item-header"><span class="pbslideshow-num-images">11/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn2-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-2020-07-16t012019-314.jpg" alt="Meanwhile in Florida…Woman Sues for Paternity Test on Goats (But Not for the Reason You Think)" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn2-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-2020-07-16t012019-314.jpg" alt="Meanwhile in Florida…Woman Sues for Paternity Test on Goats (But Not for the Reason You Think)" width="600" height="400"/></noscript><div class="listicle-description"><h2>Meanwhile in Florida…Woman Sues for Paternity Test on Goats (But Not for the Reason You Think)</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1551394-meanwhile-in-florida-woman-sues-for-paternity-test-on-goats" >click here.</a></p><h6><em><span style="color: #999999;">Photo Credit: SOPA Images via Getty Images</span></em></h6></div></li><li id="pb_listicle_image_12" class="listicle-item js-inview-listicle" data-current-image="12"><header class="listicle-item-header"><span class="pbslideshow-num-images">12/12</span></header><img class="lazy lazy-hidden listicle-img" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" data-lazy-type="image" data-lazy-src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-91.jpg" alt="Trump’s Terrorist Theory of 75-Year-Old Man Shoved by Police Exhibits New Expert Level of Sociopathic Thinking" width="600" height="400"/><noscript><img class="listicle-img" src="https://cdn1-www.mandatory.com/assets/uploads/gallery/weird-news-7-21-2020/webp-net-resizeimage-91.jpg" alt="Trump’s Terrorist Theory of 75-Year-Old Man Shoved by Police Exhibits New Expert Level of Sociopathic Thinking" width="600" height="400"/></noscript><div class="listicle-description"><h2>Trump’s Terrorist Theory of 75-Year-Old Man Shoved by Police Exhibits New Expert Level of Sociopathic Thinking</h2><p>For more weird news, <a href="https://www.mandatory.com/fun/1549353-trumps-terrorist-theory-of-75-year-old-man-shoved-by-police" >click here. </a></p><h6><em><span style="color: #999999;">Photo Credit: Pool, Getty Images</span></em></h6></div></li></ul></section><div id="pb-listicle-slides"></div> <h2 style="text-align: center;"><span style="color: #999999;">Biden vs. Trump:</span> <a href="https://www.mandatory.com/culture/1553804-biden-vs-trump-which-political-candidate-has-better-hair" target="_blank" rel="noopener"><span style="color: #ff0000;">Which Political Candidate Has Better Hair?</span></a></h2><p><em>Visit the <a href="https://evolve-media-llc.myshopify.com/collections/mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://evolve-media-llc.myshopify.com']);" target="_blank" rel="noopener"><span style="color: #ff0000;"><strong>Mandatory Shop</strong></span></a> for great deals on your very own Mandatory merch.</em></p><p><em>Follow <span style="color: #ff0000;">Mandatory</span> on <a href="https://www.facebook.com/MANDATORY/" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://www.facebook.com']);" target="_blank" rel="noopener">Facebook</a>, <a href="https://twitter.com/Mandatory" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://twitter.com']);" target="_blank" rel="noopener">Twitter</a>, and <a href="https://www.instagram.com/mandatorydotcom/?hl=en" onclick="javascript:_gaq.push(['_trackEvent','outbound-article','http://www.instagram.com']);" target="_blank" rel="noopener">Instagram</a>.</em></p><div class="pw-server-widget" data-id="wid-kf84dv71"></div><div class="single-bottom"><div class="OUTBRAIN" data-src="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody" data-widget-id="AR_1" data-ob-template="Mandatory"></div><div id="pb-spotim-comments-widget-2" class="widget_pb-spotim-comments-widget"><div id="comments-anchor" class="spot-im-comments comments-area"> <script async
data-spotim-module="spotim-launcher"
data-article-tags="2020, 2020 democrats, 2020 election, announcement, Best of, biden, Biden Harris, campaign, candidates, Carly Rae Jepson, democrat, Donald Trump, election, fails, Fake News, fun, funniest, funniest of the week, funny, funny news, haha, Joe Biden, Kamala Harris, latest news, lol, Missy Modell, National Voter Registration Day, news, Policy, political news, political satire, politicians, politics, president, presidential, presidential election, presidential race, register, register to vote, ridiculous news, running mate, satire, senator, social-media, strange news, today&#039;s funny photos, Trump, vice-president, video, Videos, vote, voter registration, VP, weird news"
src="https://launcher.spot.im/spot/sp_xH5I96hV"
data-social-reviews="false"
data-post-id="1555788"
data-post-url="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody"
data-short-url="https://www.mandatory.com/?p=1555788"
data-messages-count="10"
data-wp-import-endpoint="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody/feed/spotim"
data-facebook-url="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody"
data-disqus-shortname=""
data-disqus-url="https://www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody"
data-disqus-identifier="1555788 https://www.mandatory.com/?p=1555788"
data-community-question=""
data-seo-enabled="false"
data-wp-v="p-4.5.2/wp-782"
></script> </div></div></div><div class="single-tags"><a href="https://www.mandatory.com/tag/2020" rel="tag">2020</a><a href="https://www.mandatory.com/tag/2020-democrats" rel="tag">2020 democrats</a><a href="https://www.mandatory.com/tag/2020-election" rel="tag">2020 election</a><a href="https://www.mandatory.com/tag/announcement" rel="tag">announcement</a><a href="https://www.mandatory.com/tag/best-of" rel="tag">Best of</a><a href="https://www.mandatory.com/tag/biden" rel="tag">biden</a><a href="https://www.mandatory.com/tag/biden-harris" rel="tag">Biden Harris</a><a href="https://www.mandatory.com/tag/campaign" rel="tag">campaign</a><a href="https://www.mandatory.com/tag/candidates" rel="tag">candidates</a><a href="https://www.mandatory.com/tag/carly-rae-jepson" rel="tag">Carly Rae Jepson</a><a href="https://www.mandatory.com/tag/democrat" rel="tag">democrat</a><a href="https://www.mandatory.com/tag/donald-trump" rel="tag">Donald Trump</a><a href="https://www.mandatory.com/tag/election" rel="tag">election</a><a href="https://www.mandatory.com/tag/fails" rel="tag">fails</a><a href="https://www.mandatory.com/tag/fake-news" rel="tag">Fake News</a><a href="https://www.mandatory.com/tag/fun" rel="tag">fun</a><a href="https://www.mandatory.com/tag/funniest" rel="tag">funniest</a><a href="https://www.mandatory.com/tag/funniest-of-the-week" rel="tag">funniest of the week</a><a href="https://www.mandatory.com/tag/funny" rel="tag">funny</a><a href="https://www.mandatory.com/tag/funny-news" rel="tag">funny news</a><a href="https://www.mandatory.com/tag/haha" rel="tag">haha</a><a href="https://www.mandatory.com/tag/joe-biden" rel="tag">Joe Biden</a><a href="https://www.mandatory.com/tag/kamala-harris" rel="tag">Kamala Harris</a><a href="https://www.mandatory.com/tag/latest-news" rel="tag">latest news</a><a href="https://www.mandatory.com/tag/lol" rel="tag">lol</a><a href="https://www.mandatory.com/tag/missy-modell" rel="tag">Missy Modell</a><a href="https://www.mandatory.com/tag/national-voter-registration-day" rel="tag">National Voter Registration Day</a><a href="https://www.mandatory.com/tag/news" rel="tag">news</a><a href="https://www.mandatory.com/tag/policy" rel="tag">Policy</a><a href="https://www.mandatory.com/tag/political-news" rel="tag">political news</a><a href="https://www.mandatory.com/tag/political-satire" rel="tag">political satire</a><a href="https://www.mandatory.com/tag/politicians" rel="tag">politicians</a><a href="https://www.mandatory.com/tag/politics" rel="tag">politics</a><a href="https://www.mandatory.com/tag/president" rel="tag">president</a><a href="https://www.mandatory.com/tag/presidential" rel="tag">presidential</a><a href="https://www.mandatory.com/tag/presidential-election" rel="tag">presidential election</a><a href="https://www.mandatory.com/tag/presidential-race" rel="tag">presidential race</a><a href="https://www.mandatory.com/tag/register" rel="tag">register</a><a href="https://www.mandatory.com/tag/register-to-vote" rel="tag">register to vote</a><a href="https://www.mandatory.com/tag/ridiculous-news" rel="tag">ridiculous news</a><a href="https://www.mandatory.com/tag/running-mate" rel="tag">running mate</a><a href="https://www.mandatory.com/tag/satire" rel="tag">satire</a><a href="https://www.mandatory.com/tag/senator" rel="tag">senator</a><a href="https://www.mandatory.com/tag/social-media" rel="tag">social-media</a><a href="https://www.mandatory.com/tag/strange-news" rel="tag">strange news</a><a href="https://www.mandatory.com/tag/todays-funny-photos" rel="tag">today&#039;s funny photos</a><a href="https://www.mandatory.com/tag/trump" rel="tag">Trump</a><a href="https://www.mandatory.com/tag/vice-president" rel="tag">vice-president</a><a href="https://www.mandatory.com/tag/video" rel="tag">video</a><a href="https://www.mandatory.com/tag/videos" rel="tag">Videos</a><a href="https://www.mandatory.com/tag/vote" rel="tag">vote</a><a href="https://www.mandatory.com/tag/voter-registration" rel="tag">voter registration</a><a href="https://www.mandatory.com/tag/vp" rel="tag">VP</a><a href="https://www.mandatory.com/tag/weird-news" rel="tag">weird news</a></div></article></div><div id="pb-listicle-right" class="col-right"></div><div class="single-footer"></div></div><footer class="footer"><div class="logo-footer-mandatory"><a href="/">Mandatory</a></div><div class="footer-copyright"><div class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-1398174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398174"><a href="https://www.mandatory.com/contact" >Contact Us</a></li><li id="menu-item-1398177" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1398177"><a href="http://www.mandatory.media/#/contact" onclick="javascript:_gaq.push(['_trackEvent','outbound-menu','http://www.mandatory.media']);">Advertiser Info</a></li><li id="menu-item-1398176" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398176"><a href="https://www.mandatory.com/privacy" >Privacy Policy</a></li><li id="menu-item-1398178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398178"><a href="https://www.mandatory.com/termsofuse" >Terms &#038; Conditions</a></li><li id="menu-item-1398175" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1398175"><a href="https://www.mandatory.com/cookies" >AdChoices</a></li></ul></div><div class="copyright">MANDATORY.COM IS A PROPERTY OF <a href="http://www.evolvemediallc.com">EVOLVE MEDIA</a> LLC COMPANY. &copy; 2020 ALL RIGHTS RESERVED.</div><div class="footer-affiliate">Affiliate Disclosure: Evolve Media LLC, and its owned and operated websites may receive a small commission from the proceeds of any product(s) sold through affiliate and direct partner links.</div></div></footer><aside class="widget_text widget_custom_html scripts"><span class="hidden">Pingdom</span><div class="textwidget custom-html-widget"><div style="position: absolute; left: -999em">monitoring_string = "f4e9a55d2640cb37b28a2b021fc63f8b"monitoring_string = "d597bbac21cf40e24fffa6cecdf4d8c5 "</div></div></aside><script type="text/javascript">//<![CDATA[
var _gaq = _gaq || [],PB   = window.PB || {};PB.GAAccounts     = ["UA-35762280-1"];PB.GAAuthor       = 'Mandatory Editors';PB.baseDomain     = 'craveonline.com';PB.CheckAMPCID    = false;PB.checkAB        = true;PB.baseRequestUrl = 'https://www.mandatory.com';
(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://' : 'http://') + 'stats.g.doubleclick.net/dc.js';
var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();//]]></script><div id="adoop" data-id="adoop" class="gpt-ad"></div><script async
src="https://launcher.spot.im/spot/sp_xH5I96hV?module=newsfeed"
data-spotim-module="spotim-launcher"
data-wp-v="p-4.5.2/wp-782"
></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/wp-evolve-gpt/js/pb.auto-refresh.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/pb.mediaquery.js?ver=1.7.1'></script><script type='text/javascript' src='https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/js/utils/pb.media-queries.js?ver=1.0.8'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-ajax-sidebars-2/assets/js/pb.sidebar-loader-v2.js?ver=2.0.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-listicle/assets/js/sidebars/pb.sidebars-listicle.js?ver=1.0.10'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/pb.stickify.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-listicle/assets/js/modules/pb.listicle-ads.js?ver=1.0.10'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-listicle/assets/js/modules/pb.listicle.js?ver=1.0.8'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-listicle/assets/js/controllers/pb.listicles.js?ver=1.0.11'></script><script type='text/javascript'>
var pbGAConfiguration = {"customVars":{"cv_loggedin":false,"cv_authorname":true,"cv_category":false,"cv_all_categories":false,"cv_tags":false,"cv_year":false}};
</script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-google-analytics-for-wordpress/js/pb.ga-manager.js?ver=0.0.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-google-analytics-for-wordpress/js/pb.ga-dispatcher.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-google-analytics-for-wordpress/js/pb.ga-init.js?ver=0.0.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-listicle/assets/js/controllers/pb-listicle-core.js?ver=1.0.0'></script><script type='text/javascript' src='https://widgets.outbrain.com/outbrain.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/pb.cookie.notice.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/ga-campaignTracker.js?ver=1.0.0'></script><script type='text/javascript' src='https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/js/modules/pb.header-nav.js?ver=1.0.8'></script><script type='text/javascript' src='https://cdn2-www.mandatory.com/wp-content/themes/mandatory-2018/js/modules/pb.scrollout-header.js?ver=1.0.8'></script><script type='text/javascript' src='https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/js/modules/pb.overture-scroll.js?ver=1.0.0'></script><script type='text/javascript' src='https://cdn3-www.mandatory.com/wp-content/themes/mandatory-2018/js/modules/pb.billboard-close-button.js?ver=1.0.1'></script><script type='text/javascript' src='https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/js/controllers/pb.global.js?ver=1.0.9'></script><script type='text/javascript' src='https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/js/modules/pb.sticky.js?ver=1.0.9'></script><script type='text/javascript' src='https://cdn1-www.mandatory.com/wp-content/themes/mandatory-2018/js/controllers/pb.single.js?ver=1.0.9'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/bj-lazy-load/js/bj-lazy-load.min.js?ver=2'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/wp-evolve-gpt/js/vendor/jquery.visible.js?ver=1.0.0'></script><script type='text/javascript' src='https://cdn1-www.mandatory.com/wp-includes/js/underscore.min.js?ver=1.8.3'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/wp-evolve-gpt/js/pb.gpt-ads-callbacks.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/wp-evolve-gpt/js/pb.load-gpt-ads.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/wp-evolve-gpt/js/pb.lazy-load-gpt-ads.js?ver=1.0.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-slideshow/assets/js/jquery.mousewheel.js?ver=3.0.6'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-slideshow/assets/js/jquery.jscrollpane.min.js?ver=2.0.0b12'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/jquery.history.js?ver=1.7.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/jquery.bxslider.min.js?ver=4.1.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/pb.slider.js?ver=1.0.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-slideshow/assets/js/pb.carousel.js?ver=1.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-slideshow/assets/js/pb.slideshow-lazyload.js?ver=1.0.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-slideshow/assets/js/pb.slideshow.js?ver=1.1.1'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/pb.adreloader.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pebblebed/media/js/pb.adiframereloader.js?ver=1.0.0'></script><script type='text/javascript' src='https://www.mandatory.com/wp-content/plugins/pb-slideshow/assets/js/pb.gpt-reload-slideshow.js?ver=1.1.0'></script><script type='text/javascript' src='https://cdn2-www.mandatory.com/wp-includes/js/wp-embed.min.js'></script><script src="//dashboard.evolveplatform.net/contentiq.js?url=//www.mandatory.com/culture/1555788-national-voter-registration-day-missy-modell-parody?utm_source=rss&#038;utm_medium=rss&#038;utm_campaign=national-voter-registration-day-missy-modell-parody"></script><script type="text/javascript">if(typeof jQuery != "undefined") {jQuery('.siq-expsearch-icon').each(function(){var searchBox = (jQuery(this).parents('.siq-icon-searchbox-wrap').size() > 0) ? jQuery(this).parents('.siq-icon-searchbox-wrap') : jQuery('.siq-menu-searchbox-wrap') ;var inputBox = searchBox.find('.siq-expsearch-input');jQuery(this).on('click', function () {if (!searchBox.hasClass('siq-search-open')) {searchBox.addClass('siq-search-open');inputBox.focus();} else {searchBox.removeClass('siq-search-open');inputBox.focusout();}});jQuery('body').click(function (evt) {if (evt.target.id == "siq-menu-searchbox-wrap")
return;if (jQuery(evt.target).closest('#siq-menu-searchbox-wrap').length || jQuery(evt.target).closest('.siq-icon-searchbox-wrap').length)
return;if (searchBox.hasClass('siq-search-open')) {searchBox.removeClass('siq-search-open');}});});}</script></body></html>